changing a single select box by keyboard selection does not trigger the onChange event ...

RESOLVED DUPLICATE of bug 126379

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 126379
13 years ago
13 years ago

People

(Reporter: gp, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922

changing a single select box by keyboard selection does not trigger the onChange
event when a the associated option panel is not displayed.

Reproducible: Always
Steps to Reproduce:
1. move to a select box, which has an onChange event handler, either by keyboard
or by mouse. Do not click on it so the option panel does not appear
2. make a selection using the keyboard , e.g., typing the first letter of an option
3. 

Actual Results:  
The onChange event does not fires as it would if the selection is made by the mouse

Expected Results:  
trigger the onChange event
The onchange fires when the user is done making the selection (that is, when the
control loses focus).

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
(In reply to comment #1) 
> The onchange fires when the user is done making the selection (that is, when 
the 
> control loses focus). 
>  
> *** This bug has been marked as a duplicate of 126379 *** 
 
(In reply to comment #1) 
> The onchange fires when the user is done making the selection (that is, when 
the 
> control loses focus). 
>  
> *** This bug has been marked as a duplicate of 126379 *** 
 
The bug #126379 has a long list of complaints about this behavior.  
As a lot of people said, even if Mozilla/Firefox comply with the W3C 
recommendations, this is definitely inconsistent with other browser and 
counterintuitive. I.E. it's a bug. 
 
You need to log in before you can comment on or make changes to this bug.