Implement row and column selection using mouse

VERIFIED FIXED in M16

Status

()

Core
Editor
P1
major
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: Charles Manske, Assigned: Charles Manske)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+]IN beta2 will verify after 41088 is fixed.)

(Assignee)

Description

19 years ago
When Ctrl+left mouse click (Cmd for Mac) is used in a table cell, the selection
code should find the enclosing cell and emit a notification using the
nsISelectionListener object instead of doing the usual text selection. 
This will be used by the editor to manage table element selection.
We also need methods (in the nsISelection interface?) to set and set 
"table selection" mode.
Note that this work is already done, correct, Mike?
(Assignee)

Updated

19 years ago
Blocks: 26831
(Assignee)

Updated

19 years ago
Target Milestone: M15
(Assignee)

Comment 1

19 years ago
Mike: Isn't this already checked in?

Comment 2

19 years ago
*** Bug 29393 has been marked as a duplicate of this bug. ***

Updated

19 years ago
OS: Windows NT → All
Hardware: PC → All
Target Milestone: M15 → M16
(Assignee)

Comment 3

19 years ago
I'm fairly sure Mike's part of this in layout is implemented. I need to 
implement a selection observer and other editor code to finish the feature.
Assignee: mjudge → cmanske
Target Milestone: M16 → M15
(Assignee)

Comment 4

18 years ago
We removed the selection listener code and are now implementing all of table
selection (the direct user interaction with mouse and keyboard portion) in
the layout selection code.
Table and cell selection now work. Changing summary to reflect remaining tasks:
1. Optimize for faster selection when dragging across a block of cells
2. Implement column and row selection by detecting where a user clicks in the
table.
Status: NEW → ASSIGNED
Summary: Implement "table selection mode" when Ctrl/Cmd key is down during selecting → Implement row and column selection using mouse
(Assignee)

Updated

18 years ago
Target Milestone: M15 → M16

Comment 5

18 years ago
updating keyword and status whiteboard to reflect that this is a beta 2 feature 
work bug that the Composer team deems a must fix for beta 2.
Severity: normal → major
Keywords: beta2
Priority: P3 → P1
Whiteboard: Composer feature work

Updated

18 years ago
Keywords: nsbeta2

Comment 6

18 years ago
[nsbeta2+ until 5/16]
Whiteboard: Composer feature work → [nsbeta2+ until 5/16] Composer feature work
(Assignee)

Comment 7

18 years ago
This isn't going to happen for M16 (and probably not for 6.0). User can select 
cells and drag to select all cells in column or row, or use the 
select submenu in the table menu.
Should I remove all the keywords and status whiteboard?
Target Milestone: M16 → M17
(Assignee)

Comment 8

18 years ago
Figure out a simple strategy to do this. Moving back to M16
Target Milestone: M17 → M16
(Assignee)

Comment 9

18 years ago
This core feature is done -- the selection logic to select rows and columns
works great. But the exact UI action has not been decided, so we would like 
more time to work on that issue.
Choices (not necessarily mutually exclusive):
1. When mouse over in the border region of table, find the closest cell below
the top border -- then a click will select column. When in left edge of table,
find closest cell and click there will select row. This involves straight-
forward frame geometry work that I'm too tired to try to do now!
2. When mouse over is with a few pixels of the top of the first cell in column,
click there to select column. Near left border of 1st cell in row to select row.
Again, straighforward frame geometry code needed.
3. Ctrl+double click in a cell selects a row. Other people are working on 
multiple click issues right now and this code is destined for cleanup, so this
will be very easy to do after that work is done.

Currently, you can select a row by holding Ctrl (Cmd on Mac) and clicking in
the first cell of a row to select a row. You can then drag to select multiple
contiguous rows, including dragging off of a row to unselect. Similarly, 
Ctrl/Cmd + Click down on top cell in column to select a column. This is not 
the final UI action we want since Ctrl+click in a cell should select/deselect
single cells only. But this is left in to prove the basic row/column selection
works.
Requesting time extension to complete this work, or consider the remaining 
work to be "bug", not feature for M17/beta3.

Comment 10

18 years ago
this was put back on the in list, since this is more hooking up the front-end 
with the code.
Whiteboard: [nsbeta2+ until 5/16] Composer feature work → [nsbeta2+ until 5/16]

Updated

18 years ago
Whiteboard: [nsbeta2+ until 5/16] → [nsbeta2+]IN beta2 (fix in hand)

Updated

18 years ago
Whiteboard: [nsbeta2+]IN beta2 (fix in hand) → [nsbeta2+]IN beta2
(Assignee)

Comment 11

18 years ago
Checked in 5/30.
Hold Ctrl+Shift+mouse down (Cmd+Shift+mouse down) and drag to a cell to the
left or right to trigger row selection, or drag up or down to trigger column
selection. Continue to hold keys down and move mouse up/down for multiple 
rows, or left/right for multiple columns.
Support for multiple non-contiguous blocks of cells also added:
Ctrl/Cmd+Click to select first cell. Shift+Click on the second cell. All cells
between those will be selected, and that block will append to any other 
selected cells. There are major performance problems with this, so be very 
patient! Mjudge has a bug that should fix this problem (41045)
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 12

18 years ago
 will verify after 41088 is fixed.
Whiteboard: [nsbeta2+]IN beta2 → [nsbeta2+]IN beta2 will verify after 41088 is fixed.

Comment 13

18 years ago
verified in 6/4 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.