Crash when clicking on item on regular right click menu, when sub menu is open (ex. developer tools extension menu) [@ nsTimerImpl::PostTimerEvent - nsPrintObject::Init][@ nsEventStateManager::PostHandleEvent - nsPrintObject::Init]

RESOLVED FIXED

Status

()

Core
General
--
critical
RESOLVED FIXED
14 years ago
6 years ago

People

(Reporter: Jeff F., Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/0.10.1/Firefox%20Setup%201.0PR.exe

When you open the right-click menu on any page and scroll over a sub menu like
devloper tools, than click on any item on the ORIGINAL right-click menu it
either crashes, or the sub-menu becomes disabled.

Reproducible: Always
Steps to Reproduce:
1.Right click on content
2.Select any sub-menu(like developer tools extention sub-menu)
3.Select any item on original right-click menu, such as reload

Actual Results:  
Crash, or menu is disabled

Expected Results:  
Worked...

Comment 1

14 years ago
*** Bug 268401 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
Jeff can you try with a more recent built of Firefox if the problem still persist.
Do you have any Talkback ID's?
(Reporter)

Comment 3

14 years ago
I have an error report, but i do not have an Id i am aware of. (Im a newbi on 
bug smashing). Error is on 1.0PR: most of the time disables sub-menu, crshes 
periodicly.

Updated

14 years ago
URL: ANY
Keywords: crash
Summary: Crash when clicking on item on regular right click menu, when sub menu is open (ex. developer tools extention menu) → Crash when clicking on item on regular right click menu, when sub menu is open (ex. developer tools extension menu)

Comment 4

13 years ago
Jeff, please see http://kb.mozillazine.org/index.phtml?title=Talkback

do you have Talkback installed? If you do, please make it send a report and post
the ID it gives you, here.

Also, is "developer tools" menu item from an extension? Which one? That may also
be the problem

Comment 5

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041115
Firefox/1.0.

It happened to me at least 5 times. I reported to the Talkback 4 times, here are
the IDs:
TB1881891M TB2006845Y TB2351287M TB2387909G.

I can add it is not only on original menu items: I tried to click "Mark Link as
Visited" of the extension LinkVisitor.

It is not a problem on a specific extension. It happened to me with "Charcter
Encoding" of "Right Encoding", and before it with "History" of "LinkVisitor".

Shouldn't it be in "menus" componet?

Comment 6

13 years ago
mail@rotemliss.com: this bug will move as soon as we get a stack trace from your
incident.
Keywords: talkbackid

Comment 7

13 years ago
Incident ID: 2351287
Stack Signature	nsTimerImpl::PostTimerEvent d0a1157d
Product ID	Firefox10
Build ID	2004110711
Trigger Time	2004-12-04 06:09:57.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	xpcom.dll + (0002951f)
URL visited	Not Important
User Comments	I pointed a sub-menu item on the context menu, clicked other when
sub-menu not closed > Crash.
Since Last Crash	235142 sec
Total Uptime	333386 sec
Trigger Reason	Access violation
Source File, Line No.
d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 461
Stack Trace 	
nsTimerImpl::PostTimerEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 461]
0x778b0c24
nsPrintObject::Init 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/content/base/src/nsPrintObject.cpp,
line 97]
0x0450ff56

Incident ID: 2387909
Stack Signature	nsEventStateManager::PostHandleEvent f1e239f5
Product ID	Firefox10
Build ID	2004110711
Trigger Time	2004-12-06 05:54:14.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	firefox.exe + (00280049)
URL visited	Not Important
User Comments	
Since Last Crash	32081 sec
Total Uptime	365467 sec
Trigger Reason	Access violation
Source File, Line No.
d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/content/events/src/nsEventStateManager.cpp,
line 1951
Stack Trace 	
nsEventStateManager::PostHandleEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/content/events/src/nsEventStateManager.cpp,
line 1951]
0x778b0c24
nsPrintObject::Init 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/content/base/src/nsPrintObject.cpp,
line 97]
0x0450ff56
Summary: Crash when clicking on item on regular right click menu, when sub menu is open (ex. developer tools extension menu) → Crash when clicking on item on regular right click menu, when sub menu is open (ex. developer tools extension menu) [@ nsTimerImpl::PostTimerEvent - nsPrintObject::Init][@ nsEventStateManager::PostHandleEvent - nsPrintObject::Init]
(Reporter)

Comment 8

13 years ago
I've noticed that it always has one of two effects: Firefox crashes, or the sub
menu is disabled. It never has failed to occer.

Comment 9

13 years ago
It happened on my PC too.

Comment 10

13 years ago
*** Bug 274642 has been marked as a duplicate of this bug. ***

Comment 11

13 years ago
It doesn't happen for me in my newer computer, Pentium 4 3GHZ 512MB RAM (my
older was Pentium 3 ~800Mhz 128MB RAM) - I suppose it is because of the sub-menu
manages closing till I click an option.
(Reporter)

Comment 12

13 years ago
Error Still occers in 1.0.1, Possible fix: possibly if the menu is removed right
away on mouse out it would prevent problems.

Comment 13

13 years ago
I have messed around with this more than a little, because I've been hit with it
many times using the Web Developer extension.

I've noticed a few things, which are really just one thing, which seem critical.
 I am unable to get it to happen, in any way, using Thunderbird (no extension,
just its submenus), and I can't find anywhere it happens outside the context
menu for the web developer extension.

In other words, it seems to be directly caused by said extension, and not caused
at all (or only indirectly so) by submenus themselves.

Said extension is available here:
https://addons.update.mozilla.org/extensions/moreinfo.php?category=Developer%20Tools&id=60

I would say that, among web developers, it is a fairly popular extension and has
indeed been the reason at least a few people switched from whatever browser they
were using (IE, Safari, etc.) to Firefox.

Anyway, my point is that this may simply be a bug in the extension, although I
would assert that you shouldn't be able to write any xul or css that might crash
the browser, whatever the condition.

-[Unknown]
(Reporter)

Comment 14

13 years ago
(In reply to comment #13)
> I have messed around with this more than a little, because I've been hit with it
> many times using the Web Developer extension.
> 
> I've noticed a few things, which are really just one thing, which seem critical.
>  I am unable to get it to happen, in any way, using Thunderbird (no extension,
> just its submenus), and I can't find anywhere it happens outside the context
> menu for the web developer extension.
> 
> In other words, it seems to be directly caused by said extension, and not caused
> at all (or only indirectly so) by submenus themselves.
> 
> Said extension is available here:
>
https://addons.update.mozilla.org/extensions/moreinfo.php?category=Developer%20Tools&id=60
> 
> I would say that, among web developers, it is a fairly popular extension and has
> indeed been the reason at least a few people switched from whatever browser they
> were using (IE, Safari, etc.) to Firefox.
> 
> Anyway, my point is that this may simply be a bug in the extension, although I
> would assert that you shouldn't be able to write any xul or css that might crash
> the browser, whatever the condition.
> 
> -[Unknown]

I have been able to reproduce it WITHOUT developer tools installed, try any
extention that adds a sub menu.

Updated

13 years ago
Keywords: talkbackid
I think bug 246712 is basically the same as this bug. The steps to reproduce are
the same.
Blocks: 246712

Comment 16

13 years ago
It just crashed to me, see TB11080120W when it won't be in queue for processing any more.
(Reporter)

Comment 17

13 years ago
still exists.. TB11083987Q it seems harder to produce, however.

Comment 18

13 years ago
(In reply to comment #16)
> It just crashed to me, see TB11080120W when it won't be in queue for processing
> any more.

Here it is:

Incident ID: 11080120
Stack Signature	0x06539cb8 0a8d417a
Product ID	Firefox10
Build ID	2005091517
Trigger Time	2005-10-25 10:12:22.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	
URL visited	Not Important
User Comments	Clicked on LinkVisitor in context, after pointing on sub-menu didn't open still.
Since Last Crash	71504 sec
Total Uptime	71504 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
0x06539cb8
0x778b0c24
nsMathMLChar::Stretch  [c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/layout/mathml/base/src/nsMathMLChar.cpp, line 1611]
0x26eb8007

Comment 19

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 

Still crashes or disables submenu as described.  Also on my winME box too (same build)
(Reporter)

Comment 20

12 years ago
seems reslovled, can anyone confirm?

Comment 21

12 years ago
I'm still getting this bug,
I got Thunderbird 1.5 RC2 to crash using this technique and Firefox 1.5 Final also still crashes, I mainly see it when using the undo closed tabs option from tab mix plus as the option is right next to the List of closed tabs submenu.
(Reporter)

Comment 22

12 years ago
Ah, I got it again three more TBs:TB15457766H , TB15457778X , TB15457808H
(Reporter)

Comment 23

12 years ago
this is a core issue, see: https://bugzilla.mozilla.org/show_bug.cgi?id=302584
No longer blocks: 246712
Depends on: 246712
Now that bug 246712 is fixed, you might want to recheck in tomorrow's builds to see if it is still happening.
(Reporter)

Comment 25

12 years ago
I checked to nightly build and it seems resolved to me. (as well as the whole dang browser going 100000% faster) nice job guys its now WFM
Ok, marking WORKSFORME based on comment 25.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 27

12 years ago
I can now reproduce this bug again, TB20252823Y , TB20252783M , TB20252752Z
Although significatly harder
(Reporter)

Comment 28

12 years ago
Bug needs reopened I think
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Assignee: firefox → nobody
Status: REOPENED → NEW
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk
From bug TB20252783M
destroyTimerEvent  [c:/builds/tinderbox/Fx-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/xpcom/threads/nsTimerImpl.cpp, line 467]
0x778b0c24
nsHTMLUnknownElement::nsHTMLUnknownElement  [c:/builds/tinderbox/Fx-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/content/html/content/src/nsHTMLSpanElement.cpp, line 136]
0x0674c63b

Realted to bug 327947, bug 333504 and bug 220959 I guess.
Component: General → General
Product: Core → Firefox
Version: Trunk → 1.0 Branch
Component: General → General
Product: Firefox → Core
Version: 1.0 Branch → Trunk
(Reporter)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsTimerImpl::PostTimerEvent - nsPrintObject::Init] [@ nsEventStateManager::PostHandleEvent - nsPrintObject::Init]
You need to log in before you can comment on or make changes to this bug.