No .html icon for Firefox - only default application icon

RESOLVED FIXED

Status

()

defect
--
trivial
RESOLVED FIXED
15 years ago
10 years ago

People

(Reporter: junk, Assigned: rstrong)

Tracking

Trunk
x86
Windows XP
Points:
---
Bug Flags:
blocking1.8.1.4 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 (MOOX M3)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 (MOOX M3)

For quite some time now - forget which version it started with - I have had no
Firefox .html icon even though it is clearly associated with Firefox in the
registry. I only have the default Windows application icon. I have reset the
icon cache with TweakUI, checked registry settings - nothing will change it.
Now, even resetting to IE will not give me an IE icon. Somewhere, somehow, some
version back, FF hosed the .html icon setting completely. I should note that I
do have the FF icon on FF in the top left corner, unlike another bug. (Any ideas
on how to fix?) 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Reporter

Comment 1

15 years ago
Others with the same problem. Here are two forum threads (there are a few):

http://forums.mozillazine.org/viewtopic.php?t=159801

http://forums.mozillazine.org/viewtopic.php?t=139135

Comment 2

15 years ago
Bug appeared after uninstalling FF 0.10.1 and installing FF 1.0. Cannot get
HTM/HTML file icons in WinExplorer (or Desktop or any file dialog box) to show
FF icons, even after using third-party icon manager (Style XP, in my case). Only
shows default application icon. Icon appears correctly in the File Types window
in WinExplorer, but not anywhere else.

Using WinXP Pro.
Reporter

Comment 3

15 years ago
XP

Maybe this helps point to the problem: I deleted .html and .htm from the files
list (folder options/file types), and after that, IE will now supply its icon if
set as the default browser, but FF will not. With FF I now get the unknown
application icon. However, if I right-click on an html file and choose
properties, it shows the FF icon where it says "Opens with" (also did this
before, no change there).

So why no icon on the html file itself?

Comment 4

15 years ago
I can confirm that I have the same problem. It appeared after 1.0 I believe.
Note that I use the ZIPs not the installer. Also, the change appeared gradually.
First, it was in certain applications such as my FTP client, then slowly started
to appear in things such as My Computer. Now its everywhere. I haven't tried to
reset it with Style XP or something, but I did try via the File Types dialog by
applying IE and then re-applying FF. Sounds like a conspiracy from Redmond to
keep eyes off the FF logo ... hmmm ... :)

XP Professional w/ all windows update patches *except* SP1+SP2.

Comment 5

15 years ago
The default icon for the taskbar should be the little orange globe.

I kept thinking that I had a dos box open because the little icon was left as
the standard windows system icon.

I solved the problem myself by:

C:\Program Files\Mozilla Firefox\chrome\icons\default\main-window.ico

and using the little orange and blue globe extracted from firfox.exe as the icon.

It should be this way by default.

Thanx

Comment 6

15 years ago
ABLE TO RESOLVE:  The following method worked. I could not do anything in with
the .ico file mentioned, because I have no 
C:\Program Files\Mozilla Firefox\chrome\icons\ folder.

1. Open Windows Explorer.

2. Choose Tools, Folder Options...

3. Choose File Types tab.

4. Scroll to HTM (or HTML - you may need to repeat with both) and hit Select

5. Click Advanced button (if you have a Restore... button, click that, then you
should get the Advanced button in its place).

6. Select the "open" action, and click Edit...

7. Click Browse... and browse for firefox.exe (if you put it in a default
location, it should be c:\Program Files\Mozilla Firebox\), select it and click OK.

8. You should be back on the Edit File Types dialog box. Click Change Icon...

9. Browse for and select firefox.exe (if it's not already in there). Choose the
first firefox icon.

10. OK / OK / close your way out of the dialog boxes. Your icon should be restored.
Reporter

Comment 7

15 years ago
That didn't work for me or others. But there was a thread in Mozillazine about a
registry entry error. Search for firefoxhtml in the registry under an "old icon"
entry, and the subentry has a wrong path on defaulticon. Mine was pointing to an
old nightly. 

Comment 8

14 years ago
This bug definitely is cuasing some weirdness. I suffer from this bug and
noticed it around the time he "Deer Park" brandling landed on the trunk,
although judging by the details found in this bug thread, it may not be linked
to that.

I notice that in some programs the correct Firefox page icons appear, for
example Winrar or Shareaza, and other times they don't... I can't reproduce it
always so far, but it is something you can try.

If I set my default browser to IE, the correct IE icons appear for
htm/html/xhtml/etc files, and the same happens if I set my default browser to
Opera, but as soon as I set it to Firefox I get the default program icon that
everyone here has mentioned.

The method explained in comment #6 did not work for me. The method in comment #5
is unacceptable to me, since it was working before.

Comment 9

14 years ago
Sorry to post again so soon, but I found a solution that worked for me.

More details here:
http://forums.mozillazine.org/viewtopic.php?p=1524606#1524606
and
http://forums.mozillazine.org/viewtopic.php?p=1524741#1524741

it seems to be related to MS Office HTML icon handler creating a registry
setting which creates a backup of original Firefox settings, and if and when the
directory changes, the backup does not point to the new location.

Comment 10

14 years ago
Thanks so much Bryan! After years of dealing with that cursed "Default Application" icon I can finally see the real Firefox document icon again :). 

Does anyone know anything more about that registry key, or the MS Office Icon Handler? Would it be worth filing a bug to have Firefox modify or delete that key when it changes the default browser, or is it not safe to edit?

Comment 11

14 years ago
Posted patch Patch v1 (obsolete) — Splinter Review
This fixes the bug for me. It makes Firefox look for and delete the offending IconHandler key. The code runs whenever Firefox is set as the default browser. If the key is not present, it doesn't touch the registry.

I don't have reproducible steps to get the system into the buggy state, but this patch got me out of it.

Asking Ben for review, since he seems to have written the bulk of the shell service.
Assignee: firefox → jhenry
Status: NEW → ASSIGNED
Attachment #208158 - Flags: review?(bugs)

Updated

14 years ago
Component: General → OS Integration
Version: unspecified → Trunk

Updated

14 years ago
QA Contact: general → os.integration
*** Bug 326220 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
Comment on attachment 208158 [details] [diff] [review]
Patch v1

Trying a different reviewer, since Ben seems to be overloaded (as usual :)

Asaf, if you can't review this, could you suggest another candidate? Thanks.
Attachment #208158 - Flags: review?(bugs) → review?(bugs.mano)
Attachment #208158 - Flags: review?(bugs.mano) → review?(mconnor)

Comment 14

13 years ago
I went to un-bitrot this patch, but apparently Rob Strong removed the (then unused) DeleteRegKey function. I could readd it I suppose, if a fix is wanted. I just got an email today from a user who is seeing this, asking me to try to get a patch landed.
I plan on adding some consistency for how we set the default browser in bug 356241 and elsewhere along with some of the other OS instegration hooks. Any reason you chose not to fix the path in the icon handler's registry key instead of deleting the keys under FirefoxHTML?

Comment 16

13 years ago
I was just going by what the linked MozillaZine threads suggested. I'll play around with setting the key to the correct value.

Comment 17

13 years ago
Ah, now I remember. The IconHandler is located under HKEY_CLASSES_ROOT, and the SetRegKey utility function doesn't deal with that root.

Do you have any suggestion on how to proceed, Rob?
HKCR is an abstraction of HKLM\Software\Classes and HKCU\Software\Classes. Having said that, the SetRegKey utility function is broken since it uses OpenKeyForWriting as noted in bug 356241... so, I'll take care of this at the same time I fix bug 356241 since that will require rewriting SetRegKey.
I didn't have time to fix this as part of bug 356241 but I'll get to it soon.
Assignee: jhenry → robert.bugzilla
Status: ASSIGNED → NEW
Posted patch Installer patch (obsolete) — Splinter Review
This will fix it on install and software update. Once bug 369783 is fixed this will fix it when changing from multiple installs on the same system.
Attachment #208158 - Attachment is obsolete: true
Attachment #255321 - Flags: review?(sspitzer)
Comment on attachment 255321 [details] [diff] [review]
Installer patch

r=sspitzer, but one question and one nit:

question) do we want a ClearErrors before both checks for Unless Errors?

nit) "incorrect  icon" -> "incorrect icon"
(In reply to comment #21)
> (From update of attachment 255321 [details] [diff] [review])
> r=sspitzer, but one question and one nit:
> 
> question) do we want a ClearErrors before both checks for Unless Errors?
Shouldn't be necessary here but I am going to add them if for no other reason consistency.

> nit) "incorrect  icon" -> "incorrect icon"
fixed
Checked in to trunk
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Component: OS Integration → Installer
QA Contact: os.integration → installer
note: bug 369783 will fix the default browser case and bug 369997 will handle the uninstall case
Not blocking on this old polish bug (but might consider approving the patch, haven't defined the criteria for ride-alongs yet).
Severity: normal → trivial
Flags: blocking1.8.1.4? → blocking1.8.1.4-

Comment 27

12 years ago
Call me an idiot, but I don't understand how to apply the patch. It just loads up in my browser. I've saved the file through File, Save Page As. and it saves as a .diff. Importing into Registry Editor doesn't work either if that's what I was supposed to do. 
Sorry for wasting your time.

Comment 29

11 years ago
I'm still getting this bug. 


Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Comment 30

11 years ago
(In reply to comment #29)
> I'm still getting this bug. 
> 
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906
> Firefox/3.0
> 

Update... I managed to "fix" it. The only solution that worked for me was...

1. Make IE the default browser.
2. Completely UnInstall Firefox.
3a. Go into RegEdit and delete all of the FirefoxHTML entries.
3b. Also suggest using a program like CCleaner to get rid of orphan files. 
4. Reboot.
5. ReInstall Firefox... Voilà, file association icons are fixed. 

*sigh* I was hoping to avoid a total reinstall, but since I don't use any extensions, I suppose I have it easier than most.

Comment 31

10 years ago
(In reply to comment #30)
> (In reply to comment #29)
> > I'm still getting this bug. 
> > 
> > 
> > Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906
> > Firefox/3.0
> > 
> 
> Update... I managed to "fix" it. The only solution that worked for me was...
> 
> 1. Make IE the default browser.
> 2. Completely UnInstall Firefox.
> 3a. Go into RegEdit and delete all of the FirefoxHTML entries.
> 3b. Also suggest using a program like CCleaner to get rid of orphan files. 
> 4. Reboot.
> 5. ReInstall Firefox... Voilà, file association icons are fixed. 
> 
> *sigh* I was hoping to avoid a total reinstall, but since I don't use any
> extensions, I suppose I have it easier than most.

I also had this bug up to Firefox 3.5.3 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3), but in my case the fix was a bit easier:

1. Uninstall Firefox, don't delete your profile.
2. Reinstall Firefox.

The icon for html files was back again.
You need to log in before you can comment on or make changes to this bug.