Closed Bug 268621 Opened 15 years ago Closed 14 years ago

Page Up and Page Down scroll the main view even if focus is not there

Categories

(Calendar :: Sunbird Only, defect, minor)

x86
Windows 98
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rod.whiteley, Assigned: jminta)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: 2004091012-cal Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

The Page Up and Page Down keys unexpedely scroll the main view, even if you are
only trying to scoll something else.

Reproducible: Always
Steps to Reproduce:
For example:
1. Make some tasks
2. In the list of tasks, select the top one
3. Press Page Down to move down the list

Actual Results:  
The list that has cursor focus pages normally, but the main view ALSO pages.

Expected Results:  
These keys should only affect the element of the interface that has cursor focus.

If you do this in the Events list, you see the main view flicker as it tries to
get back to the place where it was.  If you only press Page Up or Page down
once, it corrects itself.  But if you press Page Up or Page Down a couple of
times quickly, the main view cannot cope.
confirmed

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 +
2004110411-cal
Reporter:
    I can confirm this behavior in Sunbird 2.0. However, this is very closely
related to bug 250073.  The general issue is that scrolling of any kind
(mouse-wheel, page up/down, etc) always applies to the main view.  Since both
issues would likely be fixed by the same patch (making calendar recognize where
the focus is), I'm not sure if it may be better to just comment in that bug
about the expanded nature of the problem.

Leaving as unconfirmed for now, pending decision about merging with bug 250073.
 Just leave a comment if you disagree with this idea, and I'll confirm the bug.
(In reply to comment #2)
I disagree.  Although both bugs seem to be concerned with event handling, I
don't think it is certain that one patch will fix them both.  Bug 250073 has
nothing to do with focus, so a fix based on focus might not affect it.
(In reply to comment #3)

OK, I'll stick a comment in bug 250073, just in case.

Status: NEW

Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: gurganbl → sunbird
Patch moves the listeners for pg-up and pg-down into the views, rather than in calendar.xul.  The effect is that Lightning also gets these access keys.
Assignee: mostafah → jminta
Status: NEW → ASSIGNED
Attachment #225935 - Flags: first-review?(dmose)
Comment on attachment 225935 [details] [diff] [review]
move the key listeners into the views

Man, a patch that _didn't_ need to use a string bundle helper.  You're slipping, man.

r=shaver
Attachment #225935 - Flags: first-review?(dmose) → first-review+
patch checked in.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.