Closed Bug 268745 Opened 17 years ago Closed 16 years ago

Statusbar does not update correctly with tabs and links

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 104532

People

(Reporter: t1470258, Assigned: bugzilla)

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

  using: Windows NT v5.0(2000) SP4 + Firefox v1.0 b20041107 (The Official)
checked: 'clean' installs of Firefox v1.0 PR + Firefox v1.0 Official
         no preference changes, no extensions.

Firefox statusbar text doesn't update correctly & properly as expected in
actions with tabs & links. There're two issues I figured out. First(numbered)
one is reproducible 'everytime'. Second(alphabet) one is reproducible somewhat
chance and I can't find the everytime steps for it.

Below images are self-explanatory & to be used with 'actual results'
http://www.geocities.com/t1470258/screenshot001.png
http://www.geocities.com/t1470258/screenshot002.png
http://www.geocities.com/t1470258/screenshot003.png
* All images are screenshots taken consecutively


Reproducible: Always
Steps to Reproduce:
1.Open few sites with links
2.In a page, while over a link, right-click the link
3.While right-click menu shown, click another tab

a.Open few sites
b.Open a site with long loading time
c.While site is loading switch tabs
d.Repeat b & c until you get a bug

Actual Results:  
With numbered steps: If you switch back to the page you right-clicked the link,
you will see that tab's statusbar text still shows the URL of the right-clicked
link until you hover a link or perform action. Check above 2nd image for a result.

With alphabet steps (with some uncertainity): Long loading time site's statusbar
action text sticks with the last tab selected until you hover a link or perform
action. This semi-fixation affects just those tabs while others remain
unaffected. Check above 1st & 3rd images for results.


Expected Results:  
With numbered: Statusbar text should be 'Done' as it's done after you hover a
link & move cursor away.

With alphabet: Every tab should have its own statusbar text displayed in the
statusbar after the tabs are loaded. While some tabs are loading, the statusbar
text should be updated to show actions for those tabs only.
Attached image Screenshot 1
Attached image Screenshot 2
Attached image Screenshot 3
Added also attachments of the same images I linked from 
another site. Use with the 'Actual Results' section.
Sounds like a duplicate of Bug 104532.
from bug reporter:
I examined Bug 104532 ostgote@gmx.net mentioned above. I've read the original &
most of the duplicates of that bug. Bug 104532 is based on the visited webpages
having 'javascript' that 'modifies' the status bar text. Like marquee, ticker,
scroll, timer & ...

But if you check the attachments(also same linked images) here, 
you'll see the web pages shown:

http://www.mozilla.org/contribute/
http://www.mozilla.org/quality/bug-writing-guidelines.html
http://bugzilla.mozilla.org/

doesn't have that kind of script at all. Even more, first two don't have any
script & if you change the third one with another long loading non-script page,
the bug is repeated again. So this bug is not a duplicate but a similar/cousin
of Bug 104532. In a way it's more serious than the other bug since 'clean'
Firefox v1.0 does it without need for an external javascript'ed webpage.

Update Info:
The numbered bug only affects the tab with right-clicked link. -> Local
The alphabet bug affects other tabs once been 'Done' 
    before the bug occurred.                                   -> Global
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050430
Firefox/1.0+

I can confirm this bug and can still reproduce it.
CONFIRMED!

Able to reproduce this in the latest trunk nightlies using the following steps:

1) Launch Deer Park (Latest build)
2) Navigate to http://forums.mozillazine.org/ (Let page load complete)
3) Open a new tab
4) Navigate to http://www.cnn.com/
5) QUICKLY switch to the first tab!!!
6) Observe either "transferring data from www.cnn.com..." or "waiting for
i.a.cnn.net..." or something very similar in the status bar! 

I spoke to Neil on IRC (#Developers) and he stated: "just find a firefox version
of the bug, pointing out that it's not a duplicate because it works in the
suite".  The "duplicate" he refers to is bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=104532.  Apparently the Suite
doesn't experience this issue.

Is it possible to port the patches from bug
https://bugzilla.mozilla.org/show_bug.cgi?id=104532 ?

Requesting blocking1.8b3 and blocking-aviary1.1! 
Flags: blocking1.8b3?
Flags: blocking-aviary1.1?

*** This bug has been marked as a duplicate of 104532 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Flags: blocking1.8b3?
Flags: blocking-aviary1.1?
You need to log in before you can comment on or make changes to this bug.