[Mac] Default page icon (favico ) in location bar is bad

RESOLVED WORKSFORME

Status

()

--
trivial
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: waynegwoods, Assigned: bugzilla)

Tracking

({helpwanted})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041109 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041109 Firefox/0.9.1+

In the last few trunk nightlies, the default "globe" icon that appears on the
left-hand side of the location bar (where favicons are displayed) seems to have
become ragged and worn. I assume it's using the wrong image file .

Reproducible: Always
Steps to Reproduce:
1.Open a blank browser window, or navigate to a page without a site icon
2.Observe the messed-up "globe" icon in the location bar



This doesn't appear on the latest nightly for the Aviary branch, so I assume
it's trunk-only.

I can't say exactly in which build it began, but it was fine in the 20041103
nightly, and bad in the 20041107 nightly
(Reporter)

Comment 1

14 years ago
Narrowed it further to some time between the 20041103 (good icon) and 20041104
(bad icon) trunk builds. With the hour included, these builds are 2004-11-03-07
and 2004-11-04-11.
(Reporter)

Comment 2

14 years ago
Just to clarify, it's the globe icon that normally appears "fogged out" on the
location bar when a blank page is first opened. After a web page loads, it
switches to the more solid and colourful copy of the globe, and that icon
appears fine. The same can be seen on tabs... the greyed-out tabs in the
background display the ragged icon instead of the usual foggy icon, while the
foreground tab displays the normal one.

Comment 3

14 years ago
screenshot please :)
Summary: [Mac] Default page icon (favicon) in location bar is bad → [Mac] Default page icon (favico ) in location bar is bad
(Reporter)

Comment 4

14 years ago
Created attachment 166325 [details]
Displays both good and bad versions of the icon, depending on build

Attachment shows screen shots of two different trunk builds of Firefox. The
bottom one (20041103) shows the icon as it used to appear when a new window is
first opened. The top one shows the most recent nightly (20041117) with the bad
icon.

Comment 5

14 years ago
I've done some investigation and I'm not having luck figuring this out. I did
determine that the -moz-opacity: 0.5 seems to be causing the icons to look
distorted. If I remove the opacity, the icons appear normal, but without the
opacity that was intended.
Keywords: helpwanted

Comment 6

14 years ago
The icon looks bad on startup.  It also goes bad when you're entering text into
the location bar and Autocomplete pops up.  If you go to a site such as
about:blank, or any other site without an icon, the icon looks fine.
(Reporter)

Comment 7

14 years ago
This seems to have been fixed in recent builds, so resolving. Anyone know who
did it? :)
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.