External Apps open new window when Firefox set for new tab in existing window

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: John Robb, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0

Firefox will only open links from external apps in a new window no matter what I
do. Setup is Edit>Preferences>Advanced>Open links from other applications in: A
new tab in most recent window. 

Reproducible: Always
Steps to Reproduce:
1.Open Firefox
2.Open any external app with a link.
3.Click link in external app.
4.Firefox opens a new window

Actual Results:  
A new Firefox window opened and displayed the link.

Expected Results:  
Opened a new tab in the existing Firefox window.

Comment 1

13 years ago
Hmm, I currently dont see this problem - in the 1.0 relaese and nightly builds,
the last opened window IS used, but that's a problem if the last opened window
is console-type (no nav controls) because FF is hijacking the window by creating
a new, invisible tab (instaed of opening the new tab in the root window, or at
least displaying the tabs in the child window)... Example, click in 'my profile'
at https://www.breezeway.tv then click the external app link..
Ken, what you are describing is bug 243893.

John, do you still experience this problem? If not, please resolve this bug as
"WORKSFORME".
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Ken, what you are describing is bug 243893.
> 
> John, do you still experience this problem? If not, please resolve this bug as
> "WORKSFORME".

Not the same bug. I still have the problem for all users on this box.
I see this problem with Fedora Core 3 + latest updates and Firefox 1.0
(installed from FC3 channel) when clicking links from Thunderbird 0.9 (latest
version available from FC3 channel).  I have "Firefox" selected as my default
browser under GNOME's Applications -> Preferences -> More Preferences ->
Preferred Applications control panel and "a new tab in the most recent window"
selected 
in Firefox's Edit -> Preferences -> Advanced -> Tabbed Browsing -> "Open links
from other applications in:" control.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

13 years ago
I also see this problem, fedora core 3, using both firefox 1.0 (20041111 build I
think it was) and now still after applying latest updates:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2
Fedora/1.0.2-1.3.1

It was working correctly until a few days ago, but I don't know what changed (it
wasn't a firefox or thunderbird upgrade however). I have this line in prefs.js:
user_pref("browser.link.open_external", 3);

It also happens when opening links from the terminal, so is not
thunderbird-specific.

I have the following extensions: Colorzilla, CookieCuller, Viewcookies,
WebDeveloper. I believe I installed them after first noticing the tabs problem,
but perhaps not?

Updated

13 years ago
Depends on: 302281
(Reporter)

Comment 6

13 years ago
Upgraded my box from Suse9.1 to 9.3 with a clean install and I still have the
same problems.
Fixed by the checkin for bug 302281.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.