middle mouse button doesn't work as it should on OS X

RESOLVED DUPLICATE of bug 151249

Status

()

RESOLVED DUPLICATE of bug 151249
14 years ago
14 years ago

People

(Reporter: mtb19, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

This may be a dup (I didn't see it in the list, but that doesn't mean it's not
there), but the middle mouse button does not seem to work on OS X as it does on
other platforms. On Linux and Windows, when I click on a link with the middle
mouse button, I get that link opened in a new tab. On OS X nothing happens
(CMD-RTCLK does work, however).

Reproducible: Always
Steps to Reproduce:
1. Start Firefox on OS X
2. Middle-click on a link

Actual Results:  
Nothing happened.

Expected Results:  
I expected that it would have behaved like other platforms and opened a link in
a new tab.

FYI, I have tried this exclusively with Logitech mice. I have not tried other
mice, but I do know that my middle mouse button is generating events because it
works in other applications.

Comment 1

14 years ago
duplicate 151249.

*** This bug has been marked as a duplicate of 151249 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.