Closed Bug 269456 Opened 15 years ago Closed 15 years ago

Alt text box needs to show when mouse is hovered over image that is present (i.e., not missing), like in IE.

Categories

(Firefox :: Disability Access, defect)

x86
Windows XP
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 25537

People

(Reporter: aroxburgh, Assigned: aaronlev)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

An alt text box does does not show for images that are present (i.e., not
missing) in the 1.0 version of the Mozilla Firefox browser. The only work-around
I know of is to do right-click / propterties for each image, but that is a very
inconvenient way of browsing alt text information. This problem is serious
enough that users may consider migrating back to IE.

Reproducible: Always
Steps to Reproduce:
1.Go to http://www.telegoons.org/Canal_stills.htm
2.Hover mouse over any of the images. No alt text box.
3.Do same thing in any version of the IE browser and compare.

Actual Results:  
With Firefox, nothing happens.
With IE you get an alt text box.

Expected Results:  
Show the image alt text in a box as long as the mouse hovers over an image that
is present, and has alt text.

IMHO this is a very serious bug, and affects Firefox's compatibility with a
large number of web sites. You may have an opinion that the alt text was
designed for other reasons (such as giving an indication of an image's contents
if it is missing or can't be viewed due to text-only mode) but that does not
take into account how this feature is mostly used in practice, at least these
days. The URL I have given as an example is perhaps an extreme example of such
use, but the alt text box in IE privides a very simple means to achieve the
effect you'll see at that url using IE.
This behavior is correct.  Showing a tooltip is not, and this is not going to
change.  See the very long discussion in the dup bug.

*** This bug has been marked as a duplicate of 25537 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.