dragging scrollbar thumb causes page to scrollbar back and forth

VERIFIED DUPLICATE of bug 22512

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 22512
19 years ago
18 years ago

People

(Reporter: A. Lee, Assigned: Peter Trudelle)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
User-Agent: Mozilla/5.0 [en-US] (Linux; I)
BuildID:    2000020708
When I drag the scrollbar thumb, it tries to scroll back to its
original position.

Reproducible: Sometimes
Steps to Reproduce:
1.open mozilla window
2.goto http://www.mozilla.org/status
3.move cursor to vertical scrollbar, just above the down arrow button.
  (need to be within the height of the scrollbar thumb above the down
   button.)
4.don't move the cursor.
5.left click so that the thumb go all the way down to the bottom.
6.don't move the curosr, yet.
7.press and hold left mouse button, drag the thumb up.

Actual Results:  The page scrolls up when dragging the scrollbar up. However, it
tries
to scrollbar down to the original position (bottom) and the page looks
flashing. When stop dragging, the page scrolls back to the bottom most
position.

Expected Results:  The page should scroll up without trying to scroll back to
the original
position.
(Reporter)

Comment 1

19 years ago
Maybe this bug depends on Bug #22512...
(Assignee)

Comment 2

19 years ago
resolving as a dup of 22512 per evaughan, who already has a fix for this in his 
tree.  I know it sounds like a distinct problem, but he sees the root cause as 
being the same.  QA should still be sure to test this scenario as part of the 
fix for 22512, rather than just verifying as a dup.

*** This bug has been marked as a duplicate of 22512 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Sorry for the spam, changing QA contact.
QA Contact: paulmac → jrgm

Comment 4

18 years ago
tested the variation of this bug noted above -- using 0509 mac/linux/win32
no problems remain . Verified dupl.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.