Remove X-Mozilla-Status headers from incoming email

RESOLVED DUPLICATE of bug 196749

Status

MailNews Core
Networking
RESOLVED DUPLICATE of bug 196749
13 years ago
9 years ago

People

(Reporter: Fnord, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I'm using Mozilla Mail 1.7...

I've noticed an increase in spam messages that are apparently including a
X-Mozilla-Status header in the incoming message. The messages appear in my inbox
with various symptoms: status set to "Replied", hilighted with a label, marked
as already-read, etc. The last is especially annoying because I'll POP down 6
messages but only see 3 "new" messages -- so I have to hunt through the inbox to
find the stealth spam. [Many are also setting bogus Date headers, so these
messages are buried amongst previous weeks/months email.]

AFAIK, all this stuff is controlled by the X-Mozilla-Status (and
X-Mozilla-Status2?] headers, and these headers should never be expected from
incoming email.

Reproducible: Sometimes
Steps to Reproduce:
I'm not sure how to reproduce/validate this, by the time the message is in the
inbox it's too late. Any way to dump the unfiltered incoming data to a logfile?

Comment 1

13 years ago
this has already been fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core

Updated

12 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 196749 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.