Passwords in Password Manager too easy to access, while Master Password feature is too inflexible

RESOLVED DUPLICATE of bug 259648

Status

RESOLVED DUPLICATE of bug 259648
14 years ago
14 years ago

People

(Reporter: furrypandy, Assigned: dveditz)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If I don't set a Master Password, the passwords in the Password Manager are
easily viewable. 

If I set the Master Password though, although the passwords are viewable, but I
need to enter the master password whenever I type into a form for the first
time, which is not desired. For example, if my dad is using the computer and
there's a master password set, and he wants to login to his Yahoo! account, it
will keep prompting him for a Master Password which he has no clue about. For
every letter he types, the Master Password prompts him.

What I propose is a configuration of the Master Password thus making it more
flexible. For example:

------------Master Password-----------
Prompt for Master Password when:
 (checkbox) Entering web forms for the first time
 (checkbox) Password Manager
--------------------------------------

That way everyone will be happy, my dad can use his Yahoo!, and I don't need to
worry about someone accessing my passwords.

This problem affects Mozilla Firefox, the Mozilla Suite (which doesn't even have
a Master Password feature) and Mozilla Thunderbird as well.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
*** Bug 269743 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
I very much agree.
Moreover, these checkboxes will immidietly explain what master password is and
does. Much better than lenghy paragraphs, help topics and all manuals put together.

There is no UI clutter because Master Password Dialog is not often used and seen
anyway.
(Reporter)

Comment 3

14 years ago
I'm sorry, Mozilla also has a Master Password feature.

By the way, in Firefox, there should also be an option to reset master passwords
so that a guest user can't lock you from accessing forms.

*** This bug has been marked as a duplicate of 259648 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.