Proxy: "save as web page complete" triggers http request with senseless url

RESOLVED DUPLICATE of bug 249508

Status

Core Graveyard
File Handling
RESOLVED DUPLICATE of bug 249508
13 years ago
2 years ago

People

(Reporter: kai-uwe.wedhorn, Assigned: Darin Fisher)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913

When Mozilla is configured to use a proxy and you save a web page with images as
"web page complete", named e.g. "UNIQUE.html", Mozilla generates http-requests
for the images where the url contains "UNIQUE_files/".
This normally makes no sense for the server and a "404 Not Found" is returned.
But  correctly saved images can be found in the local directory "XYZ_files/". So
these http-requests are superfluous as well.

Reproducible: Always
Steps to Reproduce:
1. Set up a proxy between Mozilla and the web, e.g. Squid listening on port 3128
2. Set up Mozilla to use this proxy
3. Visit a web page with images, e.g. http://www.mozilla.org/
4. (Start a tcp-logger to catch the traffic between Mozilla and the proxy)
   Save the page as "web page complete" named e.g. "A_UNIQUE_NAME.html"
Actual Results:  
The tcp-log contains http-requests like:
GET http://www.mozilla.org/A_UNIQUE_NAME_files/t_firefox.gif
GET http://www.mozilla.org/A_UNIQUE_NAME_files/mozilla16.png
...
(plus the corresponding "404 Not Found"-responses).
The web page was saved correctly including all images.

Expected Results:  
Avoid these http-requests.

1. With "Direct connection to the Internet" there are none of these http-request.
2. This behaviour seems to have started with version 1.4. Mozilla 1.3.1 is okay.
hmm, bug 249508 reports the same issue... likely the same, but just marking
dependency for now
Depends on: 249508

Updated

13 years ago
Summary: "save as web page complete" via proxy triggers http request with senseless url → Proxy: "save as web page complete" triggers http request with senseless url
ok, really the same issue. (and unrelated to proxies)

*** This bug has been marked as a duplicate of 249508 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
No longer depends on: 249508
Resolution: --- → DUPLICATE

Comment 3

13 years ago
-> file handling
Component: Networking → File Handling
QA Contact: benc → ian
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.