Firefox and JRE 5.0 doesn't work with MSIE-browser agent

VERIFIED DUPLICATE of bug 83376

Status

()

defect
--
major
VERIFIED DUPLICATE of bug 83376
15 years ago
15 years ago

People

(Reporter: alisencer, Assigned: bugzilla)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

If general.useragent.override is set to an MSIE useragent (*), then viewing a
web-page with an embedded applet shows a blank where the applet should be. On
one system of mine it shows a very obscure error-message-popup-box, on the other
I get no message at all.

(*) example: 
user_pref("general.useragent.override", "Mozilla/4.0 (compatible; MSIE 6.0;
Windows NT 5.1;)");

Reproducible: Always
Steps to Reproduce:
1. Make sure you have JRE 5.0 installed ( jre-1_5_0-windows-i586.exe )
2. Go in your profiles folder, add the following line:

user_pref("general.useragent.override", "Mozilla/4.0 (compatible; MSIE 6.0;
Windows NT 5.1;)");

3. Close and restart your browser and view a page with an applet, e.g.

http://java.sun.com/applets/other/TumblingDuke/index.html
Actual Results:  
The applet is missing - the place is blank. And on some systems I get an obscure
error message pop-up about a NullPointerException at
"com.sun.deploy.net.proxy.WNetscape4ProxyConfig.getNSversion(Unknown Source)"
, screenshots are here:
http://www.sencer.de/article/671/

Expected Results:  
The applet should have loaded and be displayed.

I assume this is related to the way the JRE is invoked.
(Reporter)

Updated

15 years ago
Version: unspecified → 1.0 Branch

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.