crash if I try to load certain page [@ GetNearestContainingBlock]

RESOLVED DUPLICATE of bug 194952

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 194952
13 years ago
7 years ago

People

(Reporter: Kai Ehlers, Assigned: Blake Ross)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

When I try to load a page in the submenu of www.dhl.de the browser crashes.

Reproducible: Always
Steps to Reproduce:
1. Open http://www.dhl.de
2. Go to "Information"
3. Load menuitem: "Downloadcenter"
Actual Results:  
Firefox exits with crash

Expected Results:  
Page "downloadcenter" should appear

I tried to visit the site with safe-mode enabled but the problem persists. When
starting Firefox from the shell the program exits with the following message on
the commandline (error with memory access): 

"./run-mozilla.sh: line 451:  3880 Speicherzugriffsfehler  "$prog" ${1+"$@"}

Talkback-Id: TB1963970X

Comment 1

13 years ago
WFM: Windows XP, 1.0
Keywords: crash
(Reporter)

Comment 2

13 years ago
Maybe this helps:
For reproduction of this bug: If you are able to view the "Downloadcenter"-Page
(happened to me once) try to click any of the menuitems i.e.:"AGB" at least at
this point my browser crashes.  

I created a new user account on my linux system and installed Firefox 1.0, the
problem as described still persists. After that I downloaded a nightly build:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041115 Firefox/0.9.1+

The problem seems to be fixed here - I wasn't able to reproduce this error anymore.

Comment 3

13 years ago
GetNearestContainingBlock() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsHTMLReflowState.cpp,
line 642]
nsHTMLReflowState::InitAbsoluteConstraints() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsHTMLReflowState.cpp,
line 613]
nsHTMLReflowState::InitConstraints() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsHTMLReflowState.cpp,
line 1844]
nsHTMLReflowState::nsHTMLReflowState() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsHTMLReflowState.cpp,
line 308]
nsAbsoluteContainingBlock::ReflowAbsoluteFrame() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsAbsoluteContainingBlock.cpp,
line 421]
nsAbsoluteContainingBlock::Reflow() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsAbsoluteContainingBlock.cpp,
line 201]
nsBlockFrame::Reflow() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 961]
nsBlockReflowContext::ReflowBlock() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 546]
nsBlockFrame::ReflowBlockFrame() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 95]
nsBlockFrame::ReflowLine() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 545]
nsBlockFrame::ReflowDirtyLines() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2098]
nsBlockFrame::Reflow() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 817]
nsBlockReflowContext::ReflowBlock() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 546]
nsBlockFrame::ReflowBlockFrame() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 95]
nsBlockFrame::ReflowLine() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 545]
nsBlockFrame::ReflowDirtyLines() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2098]
nsBlockFrame::Reflow() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 817]
nsBlockReflowContext::ReflowBlock() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 546]
nsBlockFrame::ReflowBlockFrame() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 95]
nsBlockFrame::ReflowLine() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 545]
nsBlockFrame::ReflowDirtyLines() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2098]
nsBlockFrame::Reflow() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 817]
nsAbsoluteContainingBlock::ReflowAbsoluteFrame() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsAbsoluteContainingBlock.cpp,
line 448]
nsAbsoluteContainingBlock::IncrementalReflow() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsAbsoluteContainingBlock.cpp,
line 331]
nsBlockFrame::Reflow() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 638]
nsContainerFrame::ReflowChild() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
CanvasFrame::Reflow() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsHTMLFrame.cpp,
line 554]
nsBoxToBlockAdaptor::Reflow() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp,
line 884]
nsBoxToBlockAdaptor::DoLayout() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp,
line 628]
nsBox::Layout() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsScrollBoxFrame::DoLayout() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsScrollBoxFrame.cpp,
line 337]
nsBox::Layout() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsContainerBox::LayoutChildAt() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsContainerBox.cpp,
line 654]
nsGfxScrollFrameInner::Layout() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 1421]
nsGfxScrollFrame::DoLayout() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 1272]
nsBox::Layout() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsBoxFrame::Reflow() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/xul/base/src/nsBoxFrame.cpp,
line 868]
nsGfxScrollFrame::Reflow() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 870]
nsContainerFrame::ReflowChild() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
ViewportFrame::Reflow() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsViewportFrame.cpp,
line 252]
IncrementalReflow::Dispatch() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 53]
PresShell::ProcessReflowCommands() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6397]
ReflowEvent::HandleEvent()
PL_HandleEvent() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/plevent.c,
line 674]
PL_ProcessPendingEvents() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/plevent.c,
line 608]
nsEventQueueImpl::ProcessPendingEvents() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/nsEventQueue.cpp,
line 395]
event_processor_callback() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 67]
libglib-2.0.so.0 + 0x45def (0x4059adef)
libglib-2.0.so.0 + 0x23148 (0x40578148)
libglib-2.0.so.0 + 0x241a8 (0x405791a8)
libglib-2.0.so.0 + 0x245a8 (0x405795a8)
libglib-2.0.so.0 + 0x24bf7 (0x40579bf7)
libgtk-x11-2.0.so.0 + 0xd36ff (0x4029c6ff)
nsAppShell::Run() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 144]
nsAppShellService::Run() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 495]
xre_main() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/toolkit/xre/nsAppRunner.cpp,
line 692]
main() 
[/builds/tinderbox/firefox-branch-l10n/Linux_2.4.20-28.8_Clobber/mozilla/browser/app/nsBrowserApp.cpp,
line 59]
libc.so.6 + 0x15d17 (0x40949d17)

*** This bug has been marked as a duplicate of 194952 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Summary: crash if I try to load certain page → crash if I try to load certain page [@ GetNearestContainingBlock]
Crash Signature: [@ GetNearestContainingBlock]
You need to log in before you can comment on or make changes to this bug.