Tamil unicode characters mess up on "text-align: justify;"

RESOLVED DUPLICATE of bug 240914

Status

()

Core
Layout: Text
--
major
RESOLVED DUPLICATE of bug 240914
13 years ago
9 years ago

People

(Reporter: R. Rajesh Jeba Anbiah, Assigned: Prabhat Hegde)

Tracking

({intl, testcase})

1.7 Branch
All
Windows XP
intl, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

See in this page http://peddai.blogspot.com/, few texts are under "text-align:
justify;" style (for other styles, it works fine) and so the characters are
messed up. Obviously the problem is with "justify". Not to mention that it works
fine in IE.

Reproducible: Always
Steps to Reproduce:
1. Put any Tamil texts under "text-align: justify"
2. Or try this <div style="text-align: justify;">நிறையப் பேர்</div> Vs <div
style="text-align: left;">நிறையப் பேர்</div>
3. Look at this page http://peddai.blogspot.com/ (as of November 16, 2004 00:34 IST)

Actual Results:  
The "text-align: justify;" Tamil unicode texts are flipped and severely broken.

Expected Results:  
"text-align: justify;" texts have to be justified without the Tamil characters
been messed up or broken.
(Reporter)

Comment 1

13 years ago
Created attachment 166013 [details]
Test case for text-align: justify bug on Tamil

Updated

13 years ago
Assignee: aaronleventhal → prabhat.hegde
Component: Disability Access → Layout: CTL
Product: Firefox → Browser
QA Contact: bugzilla → art
Version: unspecified → 1.7 Branch
At least on Windows this depends on bug 218887.
Depends on: 218887

Updated

13 years ago
Keywords: testcase

Updated

13 years ago
Depends on: 214715, 215219
Keywords: intl

Comment 3

13 years ago
Same problem with Malayalam Unicode also. See this page:
http://kathakal.blogspot.com

Comment 4

13 years ago
Same problem with Malayalam Unicode also. See this page:
http://kathakal.blogspot.com

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 240924 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 6

13 years ago
*** This bug has been marked as a duplicate of 240914 ***

*** This bug has been marked as a duplicate of 240914 ***

Updated

12 years ago
Blocks: 163993

Updated

12 years ago
No longer blocks: 163993

Updated

12 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 7

12 years ago

*** This bug has been marked as a duplicate of 240914 ***
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: Layout: CTL → Layout: Text
QA Contact: arthit → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.