Freeze the nsPromptService ContractID

RESOLVED DUPLICATE of bug 285080

Status

()

Core
Embedding: APIs
--
enhancement
RESOLVED DUPLICATE of bug 285080
14 years ago
13 years ago

People

(Reporter: Darin Fisher, Assigned: Darin Fisher)

Tracking

Trunk
mozilla1.8beta2
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

14 years ago
Freeze the nsPromptService ContractID

Now that nsIPromptService is frozen, we also need to freeze the nsPromptService
ContractID.  This needs to be done so that consumers can: 1) access the built-in
nsIPromptService implementation, and 2) override the built-in nsIPromptService
implementation to provide a non-XUL version.

Our embedding examples show people how to override nsPromptService, and
embedders are following our examples, so we need to freeze the ContractID.

Here it is:

#define NS_PROMPTSERVICE_CONTRACTID \
 "@mozilla.org/embedcomp/prompt-service;1"

We should probably create a header file named "nsCPromptService.h" for this, or
since there are other components in the embedcomp module, we could put them all
in one header file (e.g., the WindowWatcher service).
(Assignee)

Updated

14 years ago
Blocks: 268520
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.8beta
(Assignee)

Updated

14 years ago
Depends on: 99615
(Assignee)

Comment 1

13 years ago
It looks like bz fixed this by adding the PromptService's ContractID to
nsEmbedCID.h in bug 285080.

*** This bug has been marked as a duplicate of 285080 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Target Milestone: mozilla1.8beta1 → mozilla1.8beta2
You need to log in before you can comment on or make changes to this bug.