Firefox 1.0 + Mac OS X 10.3.6 + java 1.4.2_05 + http://javaplugin.sourceforge.net/ = CRASH

RESOLVED DUPLICATE of bug 207636

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 207636
13 years ago
13 years ago

People

(Reporter: Owen Densmore, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The latest Mac OS X release apparently breaks the Firefox/Java/JavaPlugin.  To
see this, beam into http://backspaces.net/models/buttons.html.  The model will
load OK, showing a NetLogo model.  Click "setup".  Crash.

Discussions with the NetLogo team confirmed that this used to work quite well,
thus is likely new with the latest Mac OS X release.

Reproducible: Always
Steps to Reproduce:
1. Beam into http://backspaces.net/models/buttons.html
2. Let applet load.  Displays a set of buttons and additional stuff
3. Click "setup".

Actual Results:  
Firefox crashes, causing TalkBack to appear

Expected Results:  
Run the applet and show wonderful results, saving the Free World.

TB1947813E, and several others earlier.  Theme is standard default, w/ small icons.

Comment 1

13 years ago
Stack Signature	nsRDFConMemberTestNode::FilterInstantiations() 09c3c9d9
Product ID	Firefox10
Build ID	2004110711
Trigger Time	2004-11-14 12:12:05.0
Platform	MacOSX
Operating System	Darwin 7.6.0
Module	firefox-bin + (003b4ea4)
URL visited	Does not matter -- has failed on several sites
User Comments	Firefox fails (segfaults) whenever I attempt to search within the
history or the bookmarks data. This is a show stopper for me, alas, because I
use both the history and bookmarks quite a bit!
Since Last Crash	93162 sec
Total Uptime	226484 sec
Trigger Reason	SIGBUS: Bus Error: (signal 10)
Source File, Line No.
/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/templates/src/nsRDFConMemberTestNode.cpp,
line 107
Stack Trace 	
nsRDFConMemberTestNode::FilterInstantiations() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/templates/src/nsRDFConMemberTestNode.cpp,
line 107]
nsRDFConMemberTestNode::FilterInstantiations() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/templates/src/nsRDFConMemberTestNode.cpp,
line 86]
TestNode::Propagate() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/templates/src/nsRuleNetwork.cpp,
line 887]
RootNode::Propagate() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/templates/src/nsRuleNetwork.cpp,
line 887]
nsXULTreeBuilder::OpenSubtreeOf(nsTreeRows::Subtree*,() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 1610]
nsXULTreeBuilder::OpenContainer() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 692]
nsXULTreeBuilder::RebuildAll() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp,
line 692]
nsXULTemplateBuilder::Rebuild() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/templates/src/nsXULTemplateBuilder.cpp,
line 61]
nsXULDocument::AttributeChanged() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/document/src/nsXULDocument.cpp,
line 1137]
nsXULElement::SetAttrAndNotify() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2187]
nsXULElement::SetAttr() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2147]
nsXULElement::SetAttribute() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 1027]
_XPTC_InvokeByIndex()   XPCWrappedNative::CallMethod(XPCCallContext&,
XPCWrappedNative::CallMode)() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2033]
XPC_WN_CallMethod() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1287]
js_Invoke() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsinterp.c,
line 941]
js_Interpret() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsinterp.c,
line 2981]
js_Invoke() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsinterp.c,
line 958]
js_InternalInvoke() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsinterp.c,
line 1036]
JS_CallFunctionValue() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsapi.c, line
3705]
nsJSContext::CallEventHandler() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 1299]
nsJSEventListener::HandleEvent() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/dom/src/events/nsJSEventListener.cpp,
line 177]
nsEventListenerManager::HandleEventSubType() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 710]
nsEventListenerManager::HandleEvent() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1516]
nsXULElement::HandleDOMEvent() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2841]
nsXULElement::DoCommand() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 3883]
_XPTC_InvokeByIndex()   XPCWrappedNative::CallMethod(XPCCallContext&,
XPCWrappedNative::CallMode)() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2033]
XPC_WN_CallMethod() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1287]
js_Invoke() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsinterp.c,
line 941]
js_Interpret() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsinterp.c,
line 2981]
js_Invoke() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsinterp.c,
line 958]
js_InternalInvoke() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsinterp.c,
line 1036]
JS_CallFunctionValue() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/js/src/jsapi.c, line
3705]
nsJSContext::CallEventHandler() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 1299]
GlobalWindowImpl::RunTimeout() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 5350]
GlobalWindowImpl::TimerCallback() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 5712]
nsTimerImpl::Fire() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 383]
handleTimerEvent() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 450]
PL_HandleEvent() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/xpcom/threads/plevent.c,
line 674]
PL_ProcessPendingEvents() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/xpcom/threads/plevent.c,
line 608]
_md_EventReceiverProc() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/xpcom/threads/plevent.c,
line 1578]
HIToolbox.145.0.0 + 0x1fc8 (0x927d1fc8)
HIToolbox.145.0.0 + 0x223c (0x927d223c)
HIToolbox.145.0.0 + 0x66bc (0x927d66bc)
HIToolbox.145.0.0 + 0x12d54 (0x927e2d54)
HIToolbox.145.0.0 + 0x2084 (0x927d2084)
HIToolbox.145.0.0 + 0x223c (0x927d223c)
HIToolbox.145.0.0 + 0x146e4 (0x927e46e4)
HIToolbox.145.0.0 + 0x18600 (0x927e8600)
HIToolbox.145.0.0 + 0x28740 (0x927f8740)
HIToolbox.145.0.0 + 0x8db0 (0x927d8db0)
HIToolbox.145.0.0 + 0x908c (0x927d908c)
HIToolbox.145.0.0 + 0x1ca18 (0x927eca18)
HIToolbox.145.0.0 + 0x2d730 (0x927fd730)
nsMacMessagePump::GetEvent() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/widget/src/mac/nsMacMessagePump.cpp,
line 407]
nsMacMessagePump::DoMessagePump() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/widget/src/mac/nsMacMessagePump.cpp,
line 312]
nsAppShell::Run() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/widget/src/mac/nsAppShell.cpp,
line 114]
xre_main() 
[/builds/tinderbox/firefox-1.0/Darwin_7.4.0_Clobber/mozilla/toolkit/xre/nsAppRunner.cpp,
line 710]
_start()   start()


*** This bug has been marked as a duplicate of 207636 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
This problem is caused by a bug/design-flaw in Firefox 1.0 that broke
the MRJ Plugin, a fixed-up version of which is used by the Java
Embedding Plugin.  I've just released a new version (0.8.7) of the
Java Embedding Plugin that works around this bug.

http://javaplugin.sourceforge.net/
http://sourceforge.net/tracker/index.php?func=detail&aid=1063222&group_id=107955&atid=649116

(As far as I can tell this problem has nothing to do with bug 207636.)

Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.