Print/Printpreview of this page causes crash [@ nsBlockFrame::PushLines]

RESOLVED DUPLICATE of bug 265027

Status

()

Core
Layout: Block and Inline
--
critical
RESOLVED DUPLICATE of bug 265027
13 years ago
6 years ago

People

(Reporter: Michael Baffoni, Unassigned)

Tracking

({crash, qawanted})

1.7 Branch
x86
Windows XP
crash, qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

13 years ago
Steps to reproduce:
1) Go to link
2) Select File/Print Preview
3) Browser crashes

Mozilla 1.7.3 on XP SP1
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910

Talkback crashes: TB1997525Z, TB1997518M (one is a print preview, the other is a
print)

Comment 1

13 years ago
WFM in Firefox 1.0 Windows 2000 SP4

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
(Reporter)

Comment 2

13 years ago
Oh, this does not crash Firefox 1.0, but firefox does not preview it correctly -
the page looks fine in FF, but the preview only shows one page and incorrectly
puts the footer links on top of the title text.  Should I create a separate bug
for the FF behavior, or leave the FF behavior as part of this bug (since they
may be related problems)? 

Comment 3

13 years ago
Stack Signature	nsBlockFrame::PushLines 1878bfd9
Product ID	Mozilla17
Build ID	2004091008
Trigger Time	2004-11-16 15:14:37.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	gklayout.dll + (0001d67c)
URL visited
http://www.hrcalifornia.com/cid.cfm?cid=exemptcomparison_chart&skipsearch=1&print=yes
User Comments	Doing a print also crashes the application.
Since Last Crash	53 sec
Total Uptime	2813796 sec
Trigger Reason	Access violation
Source File, Line No.
d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 4218
Stack Trace 	
nsBlockFrame::PushLines 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 4218]
nsBlockFrame::PlaceLine 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 4044]
nsBlockFrame::DoReflowInlineFrames 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3516]
nsBlockFrame::DoReflowInlineFramesAuto 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3332]
nsBlockFrame::ReflowInlineFrames 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3277]
nsBlockFrame::ReflowLine 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2436]
nsBlockFrame::ReflowDirtyLines 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2097]
nsBlockFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 816]
nsBlockReflowContext::ReflowBlock 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 532]
nsBlockFrame::ReflowBlockFrame 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3056]
nsBlockFrame::ReflowLine 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2316]
nsBlockFrame::ReflowDirtyLines 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2097]
nsBlockFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 816]
nsContainerFrame::ReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsTableCellFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableCellFrame.cpp,
line 890]
nsContainerFrame::ReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsTableRowFrame::ReflowChildren 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableRowFrame.cpp,
line 965]
nsTableRowFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableRowFrame.cpp,
line 1409]
nsContainerFrame::ReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsTableRowGroupFrame::ReflowChildren 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableRowGroupFrame.cpp,
line 432]
nsTableRowGroupFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableRowGroupFrame.cpp,
line 1289]
nsContainerFrame::ReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsTableFrame::ReflowChildren 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableFrame.cpp,
line 3246]
nsTableFrame::ReflowTable 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableFrame.cpp,
line 2162]
nsTableFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableFrame.cpp,
line 2006]
nsContainerFrame::ReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsTableOuterFrame::OuterReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableOuterFrame.cpp,
line 1335]
nsTableOuterFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableOuterFrame.cpp,
line 2000]
nsBlockReflowContext::ReflowBlock 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 547]
nsBlockFrame::ReflowBlockFrame 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3056]
nsBlockFrame::ReflowLine 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2316]
nsBlockFrame::ReflowDirtyLines 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2097]
nsBlockFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 816]
nsContainerFrame::ReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsTableCellFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableCellFrame.cpp,
line 890]
nsContainerFrame::ReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsTableRowFrame::ReflowChildren 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableRowFrame.cpp,
line 965]
nsTableRowFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableRowFrame.cpp,
line 1409]
nsContainerFrame::ReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsTableRowGroupFrame::ReflowChildren 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableRowGroupFrame.cpp,
line 432]
nsTableRowGroupFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableRowGroupFrame.cpp,
line 1289]
nsContainerFrame::ReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsTableFrame::ReflowChildren 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableFrame.cpp,
line 3246]
nsTableFrame::ReflowTable 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableFrame.cpp,
line 2162]
nsTableFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableFrame.cpp,
line 2006]
nsContainerFrame::ReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsTableOuterFrame::OuterReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableOuterFrame.cpp,
line 1335]
nsTableOuterFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableOuterFrame.cpp,
line 2000]
nsBlockReflowContext::ReflowBlock 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 547]
nsBlockFrame::ReflowBlockFrame 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3056]
nsBlockFrame::ReflowLine 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2316]
nsBlockFrame::ReflowDirtyLines 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2097]
nsBlockFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 816]
nsBlockReflowContext::ReflowBlock 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 547]
nsBlockFrame::ReflowBlockFrame 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3056]
nsBlockFrame::ReflowLine 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2316]
nsBlockFrame::ReflowDirtyLines 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2097]
nsBlockFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 816]
nsContainerFrame::ReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsTableCellFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableCellFrame.cpp,
line 890]
nsContainerFrame::ReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
nsTableRowFrame::ReflowChildren 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableRowFrame.cpp,
line 965]
nsTableRowFrame::Reflow 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableRowFrame.cpp,
line 1409]
nsContainerFrame::ReflowChild 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
Assignee: core.printing → nobody
Component: Printing → Layout: Block and Inline
QA Contact: core.layout.block-and-inline
Summary: Print/Printpreview of this page causes crash → Print/Printpreview of this page causes crash [@ nsBlockFrame::PushLines]

Comment 4

13 years ago
(In reply to comment #0)
> Steps to reproduce:
> 1) Go to link
> 2) Select File/Print Preview
> 3) Browser crashes

Confirmed on my Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20040910 Win XP PRO SP2 

Talkback TB2003920H
Is this a problem with trunk builds?  Or just 1.7 branch builds?
I don't think this is a problem anymore with trunk builds. I crash with
Mozilla1.7, but not with a current trunk build (although most of the content is
not visible on print preview).

Comment 7

12 years ago
Is this a dup of Bug 265027?
Very possible, yes...  We need a separate bug on the content not showing up and
then we can mark this duplicate...
Keywords: qawanted
Ok, I filed bug 300960 for the "content not showing up on print preview" issue.

*** This bug has been marked as a duplicate of 265027 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

6 years ago
Crash Signature: [@ nsBlockFrame::PushLines]
You need to log in before you can comment on or make changes to this bug.