XSLT Parser fails to correctly render xsl:value-of elements with disable output escaping set

RESOLVED DUPLICATE of bug 98168

Status

()

RESOLVED DUPLICATE of bug 98168
14 years ago
14 years ago

People

(Reporter: rvesse, Assigned: peterv)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: http://download.mozilla.org/?product=firefox&os=win&lang=en-US

When I create an XSLT stylesheet to render a XML page certain elements of the
XML file contain XHTML code within CDATA tags which needs to be properly escaped
to render as normal XHTML when the stylesheet transforms the XML.

By setting disable-output-escaping="yes" in the xsl:value-of element I should be
able to do this but Firefox just shows the contents as raw text so I can see all
my text and XHTML without any correct formatting.  Other browsers like IE 6 and
other non-microsoft products can render this correctly showing nicely formatted
XHTML.  Output escaping is a part of the official W3C XSLT specification

Reproducible: Always
Steps to Reproduce:
1. Write a basic XML page containing an element with preformatted XHTML/HTML
within CDATA tags
2. Write a basic stylesheet to transform this and set
disable-output-escaping="yes" for the appropriate element
3. Open the XML page in the browser

Actual Results:  
See unformatted raw XHTML code from within the element

Expected Results:  
Show formatted XHTML contents of the element
(Assignee)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 98168 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.