Closed Bug 270684 Opened 17 years ago Closed 17 years ago

Pressing Tab button not consistent

Categories

(Camino Graveyard :: Accessibility, defect)

PowerPC
macOS
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 198153

People

(Reporter: wtmcgee, Assigned: mikepinkerton)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041102 Camino/0.8.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041102 Camino/0.8.2

Something that I think should be implemented in the future is a more uniform use
of the Tab key in Camino.  When I am in the browser window, with a form field
selected, I can press tab to get to the next field, and so forth.  However, the
user can never tab back to the address bar to enter in a new address, or tab
over to the google bar to search.  From a usabilty standpoint, I think it would
be better (and more consistent with other browsers) to make the tab key cycle
through these areas as well as the forms.

I am using one of the .8.2 RC builds.

Reproducible: Always
Steps to Reproduce:
1. click anywhere in browser window
2. press tab key
3. 

Actual Results:  
Focus changed to fields, but never highlighted the address bar or the Google
search bar.

Expected Results:  
When at the end of the page, the focus should shift to the address bar, the
google bar, then back to the first form on the page.
we have bugs for this already, i'm positive.
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 198153 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.