Last Comment Bug 270688 - Backspace returns to top of previous page instead of previous position in previous page
: Backspace returns to top of previous page instead of previous position in pr...
Status: RESOLVED DUPLICATE of bug 215405
:
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: general
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 14:30 PST by Loic Le Tersec
Modified: 2004-11-22 17:25 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Loic Le Tersec 2004-11-18 14:30:46 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Firefox/1.0

Type : anomaly
Impact people using keyboard instead of mouse.
Description: Suppose you browse a page named index.htm containing three links
Link1, Link2 and Link3.If you use the tab key to move inside the page you can go
to Link2 with the tab key. At this time if you press enter key, you will jump to
the page adressed by Link2. This is correctIf then you strike backspace you will
recover the page index.htm but the focus returns to top of page, instead of
recovering the Link2 position.This behavior is different from Internet
Explorer's one, and represent a problem especially if the page index.htm
contains a whole list of links.Indeed, if it is the case, it will be cumbersome
to be positionned at top of list each time we go back to index page.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Loic Le Tersec 2004-11-18 14:56:54 PST
Description:Suppose you browse a page named index.htm containing three links
Link1, Link2 and Link3.If you use the tab key to move inside the page you can go
to Link2 with the tab key. At this time if you press enter key, you will jump to
the page adressed by Link2. This is correctIf then you strike backspace you will
recover the page index.htm but the focus returns to top of page, instead of
recovering the Link2 position.This behavior is different from Internet
Explorer's one, and represent a problem especially if the page index.htm
contains a whole list of links.Indeed, if it is the case, it will be cumbersome
to be positionned at top of list each time we go back to index page.
Comment 2 OstGote! 2004-11-18 23:14:26 PST
Check if Bug 215405 applies (HTML source and HTTP headers).
Comment 3 Loic Le Tersec 2004-11-18 23:29:43 PST
(In reply to comment #2)
> Check if Bug 215405 applies (HTML source and HTTP headers).

You are perfectly right, so my bug submission was a mistake as a duplicate.
Sorry for that.
My submission was a duplicate. I withdraw it
Of course I immediatly voted for Bug 215405





*** This bug has been marked as a duplicate of 215405 ***

Note You need to log in before you can comment on or make changes to this bug.