Having an intl ENV variable set segfaults mozilla

VERIFIED DUPLICATE of bug 26252

Status

()

Core
Internationalization
P3
blocker
VERIFIED DUPLICATE of bug 26252
19 years ago
19 years ago

People

(Reporter: Daniel Egger, Assigned: Frank Tang)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
If you start MOZILLA with the LANG or LC_ALL variable set to anything
than C mozilla will segfault at startup. This is a short trace:
WEBSHELL+ = 1
WEBSHELL+ = 2
assuming d&d is off for Navigator
nsCollationUnix::Initialize mLocale = de
nsCollationUnix::Initialize mCharset = ISO-8859-1
nsCollationUnix::Initialize mLocale = de
nsCollationUnix::Initialize mCharset = ISO-8859-1

Program received signal SIGSEGV, Segmentation fault.
0x40509ade in nsCharsetMenu::CompareItemTitle (this=0x835a3b8, aItem1=0x109,
    aItem2=0x83c9510, aCollation=0x83cb0a0)
    at ../../../../src/mozilla/intl/uconv/src/nsCharsetMenu.cpp:766
766           *aItem2->mTitle, &res);

You can very easily reproduce this on any linux/glibc2 system.
Unfortunatelly I don't quite know what's the cause of this but I'm trying to
track that further.

Comment 1

19 years ago
Reassigned to ftang for I18N bug.
Assignee: rchen → ftang
Component: Localization → Internationalization

Comment 2

19 years ago
Cata, Is this related to bug 26252 that was just fixed?

Comment 3

19 years ago
Yes, that exact area of the code was changed.
(Assignee)

Comment 4

19 years ago

*** This bug has been marked as a duplicate of 26252 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

19 years ago
Verfied as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.