If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Scrolling pages in a IFRAME (when page > frame)

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: macster_smart, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

On some webpages when I make a mouse scroll over an gif animated picture the
picture is moved 

Reproducible: Always
Steps to Reproduce:
1. Go to this webpage http://www.anandtech.com/news/shownews.aspx?i=23391
2. Make a scroll over an animated gif image
3. The gif scrolls some lines 

Actual Results:  
I don't know if this is normal to happen, I gues not.


Expected Results:  
I gues scroll on gif animated pictures is a bug not a feature

When I make a scroll over an animated gif only after the gif is scrolled some
lines the webpage is scrolled

Comment 1

13 years ago
The same problem

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041110 Firefox/1.0

Comment 2

13 years ago
The banner is actually (or nowadays) a flash object in an IFRAME, and scrolls in
its own frame. Which may be a bug but not GIF related anyway. The page
(containing the flash or agif) is a few pixels too large for the IFRAME, and so
it scrolls...
Changing subject...
Summary: Scroll problem on gif pictures → Scrolling pages in a IFRAME (when page > frame)

Comment 3

13 years ago
Created attachment 179029 [details]
Testcase for IFRAME with SCROLLING=no

Comment 4

13 years ago
This problem is coming when the image or any text is placed within an IFRAME
with the SCROLLING attribute set to "NO". I have observed this behavior in many
sites where the advertisement images are placed in IFRAME. Also this is the case
with Google advertisements placed in IFRAME. This does not occur in Internet
Explorer. In IE when the SCROLLING=no is used, it will not scroll within the
IFRAME even if the content is beyond the display area.

I thinks this is a bug in Firefox which needs to be fixed.

I haved added a small testcase for this. The testcase contains a zip file with
two HTML pages; iframe-test.html and test.html. Just open the iframe-test.html
in Firefox and use the mouse-wheel to scroll-down/up and notice the behavior of
the IFRAME. Also do the same in Internet Explorer.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 6

12 years ago
What Alfred describes is not a bug with Firefox, but just bad web design. And
Satish's testcase works for me -- the iframe doesn't scroll. So assuming that
the iframe is using scrolling=no and the content in it is larger than the frame
itself this is WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.