Ability to configure event time display formatting in event box

RESOLVED WONTFIX

Status

enhancement
RESOLVED WONTFIX
15 years ago
10 years ago

People

(Reporter: urthe1neo, Unassigned)

Tracking

Details

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/0.10.1 StumbleUpon/1.998
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041112 Mozilla Sunbird/0.2b

the time display for events on the month and multiweek views take up too much of
the block.

Reproducible: Always
Steps to Reproduce:
1. set event with time

Actual Results:  
time took up unnecessary space

Expected Results:  
times should be formatable, and could be condensed to allow more of the event
title to be displayed.  for example, "11:43 PM" could be reduced to "11:43pm",
and "12:00 PM" could be reduced to "12pm". even the "M" could be removeable.  I
say offer four formats:
1- "12:00 PM", "6:15 PM"
2- "12:00pm", "6:15pm"
3- "12pm", "6:15pm"
4- "12p", "6:15p"
I would say another should be available -- 24hr format

Confirming this as an enhancement, changing summary, HW/OS -> All
Severity: minor → enhancement
Status: UNCONFIRMED → NEW
Component: General → Calendar Front End
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: event time takes up too much room → Ability to configure event time display formatting in event box
Reporter

Comment 2

15 years ago
(In reply to comment #1)
> I would say another should be available -- 24hr format

24hr meaning military time?  all-day events are already available through a
checkbox.  if you mean military time then i agree, it should be an option.

(In reply to comment #2)
> 24hr meaning military time?

Yes.

Also, doesn't the hour/minute separator change depending on locale?
I thought some places use : and some use ;

Comment 4

15 years ago
I would like the ability to not show time on the multiweek/monthly view.  Just
start with the name of the event.  I don't know if this should be a new
enhancement request or not, so I'm putting it here.
QA Contact: gurganbl → sunbird
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody

Comment 6

12 years ago
For twenty-four-hour time it seems that you could also remove the two colons:

From this:
09:00-11:00 Team Meeting

To this:
0900-1100 Team Meeting
I don't think that we should sacrify too much readability. To me, 09:00 is much, much easier to read then 0900. I think we should just keep on using the standard time formats.

Comment 8

11 years ago
time and date formats differ dramatically around the world.  in europe most times are quoted in 24 hour format (which is not considered military time as everyone uses it.)  in some countries a period is used to separate the hour from the minute.  in others, the letter h (14h30 is equivalent to 2:30 pm).  in US military time format there is no separator.  i personally prefer using the period because it is slightly faster to type.  sunbird understands a lot of these formats automatically if you use them to enter a time (i tried a few).  

but this discussion is all overkill.  all we really need is a checkbox, defaulting to unchecked, that says "display time on month view."  if its checked it should use the standard time format specified elsewhere.  it its not checked, the time should only be displayed during hover over tool tip behavior, which it is anyway.  we actually don't even need that, because most folks would probably prefer to not see the time displayed in their monthly view anyway.  

we also need the ability to change font sizes in these views - if you could squeeze more text in there you wouldn't fret so much about the time being on there.  ical does it nicely, no time displayed in the month view, double click for details. (i'd rather double click to edit, single click or hover for details.)  
Component: Sunbird Only → Calendar Views
QA Contact: sunbird → views
Depending on locale, we support both am/pm and 24hr format. I don't think we should reduce the separator characters more.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.