Wrong cursor selected for cursor:auto on anchor elements

RESOLVED DUPLICATE of bug 88688

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 88688
14 years ago
14 years ago

People

(Reporter: Sebastian Redl, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040817
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040817

The 'auto' value for the 'cursor' property should select the cursor that the
browser will display by default for that element. However, Mozilla will use the
I-beam cursor for <a href="..."> elements.

I suppose this bug is due to <a> using a nsTextFrame for being displayed, which,
in its GetCursor method, return NS_STYLE_CURSOR_TEXT if
GetStyleUserInterface()->mCursor results in NS_STYLE_CURSOR_AUTO.
http://lxr.mozilla.org/seamonkey/source/layout/html/base/src/nsTextFrame.cpp#1338


Reproducible: Always
Steps to Reproduce:
1. Go to demonstration page.
2. Hover mouse over third paragraph in the cursor: auto presentation (and never
mind the typo - the css uses the correct cursor property)

Actual Results:  
The cursor turns into an I-beam.

Expected Results:  
The cursor should turn into a hand (link pointer).
(Reporter)

Comment 1

14 years ago
Created attachment 166851 [details]
Minimal Testcase

Minimal testcase with just a single paragraph and link.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 88688 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.