Download manager stops downloading when file chooser open

RESOLVED DUPLICATE of bug 74331

Status

()

defect
RESOLVED DUPLICATE of bug 74331
15 years ago
11 years ago

People

(Reporter: bps7j, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When I have a download in progress and choose to download something else, the
first file hangs or pauses while the file chooser is open.  When I select the
desired location, all downloads resume.

I have verified this with the Networking tab on the Windows Task Manager.

Reproducible: Always
Steps to Reproduce:
1. Download a file that's large enough to take a while
2. Right-click a link on a page and select "Save Link As"
3. Wait for the file chooser to open.

Actual Results:  
The first file stops downloading in the background.

Expected Results:  
The first file should keep downloading.

Comment 1

15 years ago
Should work slightly better with trunk builds.

*** This bug has been marked as a duplicate of 74331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.