Find fast should give focus to <input> fields with labels (radio buttons, check boxes etc)

NEW
Unassigned

Status

()

P5
normal
14 years ago
2 years ago

People

(Reporter: ehlers, Unassigned)

Tracking

(Depends on: 1 bug, {helpwanted})

Trunk
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When using fast find and typing the text used in a label, focus should be given
to the label / input-field like it is given to links. This applies to
input-fields where this syntax is used:
<label for="myradiobutton">labeltext</label><input id="myradiobutton" type="radio">

Reproducible: Always
Steps to Reproduce:
1.open the mentioned url
2.enable fast find
3.type "personligt"

Actual Results:  
the text was marked

Expected Results:  
focus should also be given to the input field / label

Comment 1

14 years ago
If the textbox is focused, further fastfind is not possible. Very inconvenient.

Please reopen if I missed anything.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
It would be convenient to give focus to radiobuttons, checkboxes, and
pushbuttons including <input type="button"> and <button>text</button> based on
labels or the text on the button. Fast-find should never give focus to
text-inputs like input-fields, select-boxes and textareas since this would
impede further fast-find.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

14 years ago
oops. sorry, I misread your report, thought it was for text box inputs, not
<input>s in general. Anyways, part of your bug is covered in bug 158757, this
will be about radio/checkboxes. Setting helpwanted as it's very similar to bug
158757.
Assignee: firefox → aaronleventhal
Status: UNCONFIRMED → NEW
Component: Find Toolbar / FastFind → Keyboard: Find as you Type
Depends on: 158757
Ever confirmed: true
Keywords: helpwanted
OS: Windows XP → All
Product: Firefox → Core
Hardware: PC → All
Summary: Find fast should be able to give focus to input fields with labels → Find fast should give focus to <input> fields with labels (radio buttons, check boxes etc)
Version: unspecified → Trunk
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey

Comment 4

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
Mass un-assigning bugs assigned to Aaron.
Assignee: aaronleventhal → nobody
Hi,
To see the bug in live : http://www.quirksmode.org/css/focus.html
Can still see this in Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre)
Gecko/20101207 Firefox/4.0b8pre and Mozilla/5.0 (X11; Linux x86_64;
rv:2.0b8pre) Gecko/20101205 Firefox/4.0b8pre SeaMonkey/2.1b2pre

=> Moving to Toolkit
Status: UNCONFIRMED → NEW
Component: Find In Page → Find Toolbar
Ever confirmed: true
Product: SeaMonkey → Toolkit
QA Contact: fast.find
Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.