When using "Find in this page", allow method to give focus back to web page.

RESOLVED DUPLICATE of bug 259454

Status

()

Toolkit
Find Toolbar
--
enhancement
RESOLVED DUPLICATE of bug 259454
14 years ago
10 years ago

People

(Reporter: Brian 'netdragon' Bober, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
If the "Find in this page" dialog on the bottom of the browser has focus, you
can't hit enter to follow links. Enter, instead, searches within the page. I
suggest allowing someone to hit Escape to highlight the selected link. In
summary, hitting escape would drop you down to normal type-ahead find mode (with
the find dialog not having focus), or if type-ahead find isn't enabled, just
have that link selected so you can click enter on it.

How to reproduce:
1) Go to http://www.google.com
2) Type CTRL+F
3) Type "Advertising Prog"
4) See that there is no way to keyboard navigate to the link quickly. Hitting
enter just does another search

Off-topic, but related: You also can't keyboard navigate to Find New, Find
Previous, and Highlight within this bar.
That's kind of an obvious statement "if something that isn't the link has focus,
you can't hit enter to follow the link that doesn't have focus"

If you want to use old-style TAF then turn it on from
Tools->Options-Advanced->Start finding when I begin typing and this works. 
There just isn't a way to have focus be in two places at once.
Assignee: aaronleventhal → firefox
Component: Keyboard Navigation → Find Toolbar / FastFind
QA Contact: jruderman
(Reporter)

Comment 2

14 years ago
That's why hitting escape would return focus to the page. I'll write a better
summary.
Severity: major → enhancement
Summary: Using "Find in this page" doesn't allow you to hit enter to follow links → When using "Find in this page", allow method to give focus back to web page.
Assignee: firefox → nobody
QA Contact: fast.find
Fixed in bug 259454.

*** This bug has been marked as a duplicate of 259454 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.