css width and height attributes are being ignored when using display:inline

RESOLVED DUPLICATE of bug 50626

Status

()

RESOLVED DUPLICATE of bug 50626
14 years ago
14 years ago

People

(Reporter: philipproessler, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041122 Firefox/1.0

the following code does not draw a 100px wide square as it's supposed to. 
instead, a rectangle is drawn just as wide as the text "i'm a box".
<div style="display:inline;
            background-color:red;
	    width:100px;
            height:100px;">
i'm a box
</div>

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
A rectangle just as wide and high as the text inside the div.

Expected Results:  
Draw a 100px x 100px square

*** This bug has been marked as a duplicate of 50626 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.