Switch "back" to using xpcom-restart instead of argv-restart

RESOLVED WONTFIX

Status

()

defect
P3
normal
RESOLVED WONTFIX
15 years ago
2 years ago

People

(Reporter: benjamin, Unassigned)

Tracking

unspecified
mozilla1.9alpha1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
The code that I wrote originally to do xpcom-restart will fix a number of
problems on mac with MacLaunchHelper and the "bouncing ball" phenomenon. And
it's just nicer, and prevents needing all those nasty environment variables. So
let's turn it "back" on. This will give us an alpha (do we only have one left?)
to catch static-initialization errors.

Comment 1

15 years ago
sure, let's give it a try.

Comment 2

15 years ago
should we also try to actually unload libraries in the process?
(Reporter)

Updated

15 years ago
Blocks: 255873

Comment 3

15 years ago
The current nsAppRunner:LaunchChild seems to have problems under BeOS too
(especially with several calls to it). BeOS has execv as well, and I've tried
using it, but it just don't work well. Probably due to library loading under
BeOS and how widgets are implemented under BeOS. It's a bit hard to track down.

Updated

15 years ago
Blocks: 266252

Comment 4

15 years ago
Is there any progress on this issue?
(Reporter)

Updated

14 years ago
Priority: -- → P3
Target Milestone: --- → mozilla1.9alpha1

Updated

14 years ago
No longer blocks: 266252

Updated

14 years ago
Blocks: 129411
(Reporter)

Comment 5

14 years ago
*** Bug 302701 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

14 years ago
Depends on: 316414

Comment 6

13 years ago
I'll be happy when this is fixed.  It has caused me pain in several ways:

* It interferes with code that expects "./firefox" to only return when Firefox actually exits (e.g. in bug 329066).

* On Mac, Firefox doesn't get focus if launched from the Mac OS X dock, and often ends up behind other windows.

Comment 7

13 years ago
Jesse: You can suppress the restart FWIW.  Just define NO_EM_RESTART=1 in your environment.

Comment 8

13 years ago
It's also preventing Firefox to be well integrated with the BeOS-platform. For instance clicking on HTML-files so that they open in Firefox can't be done in a clean way as long as this exists.

Comment 9

13 years ago
I think Mac OS X has the same problem as BeOS (comment 8).  When I drag a file to the Firefox dock icon, Firefox doesn't load that file and instead loads my home page if the last Firefox build I launched was a different one.

Comment 10

13 years ago
I'm considering adding as workaround 
export NO_EM_RESTART=1
to BeOS section of firefox start-script file.

As we cannot get rid of startscript in BeOS anyway, until this problem is solved.
Maybe I'll open separate bug for this intended workaround

Updated

13 years ago
Blocks: 338454

Comment 11

13 years ago
Wondering if for BeOS native be_roster->Launch() will work better than execv/execve from POSIX compatibility layer:
http://community.livejournal.com/bezilla/194284.html?replyto=1069036

Comment 12

13 years ago
Shouldn't this bug have a higher priority since it's causing problems for both MacOS and BeOS.

For BeOS I think it's at least a major severity.

Comment 13

13 years ago
Most of the annoyances that this causes on the Mac have been dealt with in bug 345057.
(Reporter)

Comment 14

12 years ago
Not actively working on this.
Assignee: benjamin → nobody

Updated

12 years ago
QA Contact: nobody → xre.startup

Updated

11 years ago
Component: XRE Startup → Startup and Profile System
QA Contact: xre.startup → startup
(Reporter)

Comment 15

2 years ago
I can confidently say that we will never fix this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.