One FireFox window can block resources to a second window

RESOLVED DUPLICATE of bug 74331

Status

()

RESOLVED DUPLICATE of bug 74331
14 years ago
14 years ago

People

(Reporter: sean, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

It seems that two FireFox windows are perhaps behaving as a single, multi-window
application where the core aplication is getting tongue-tied over actions that
fight for resources between the two windows. At least, that's my guess. VERY
easy to reproduce and can be quite frustrating if you have half a dozen or more
windows open and you have to go looking for which one is holding up the show.
The example I give below to reproduce the problem may be only one of several
possible ways to reproduce it, but I'm betting they're all related from an
application architecture standpoint.

Reproducible: Always
Steps to Reproduce:
1. Open a FireFox browser window and direct it to www.google.com
2. Hit CTRL-N to spawn a new window and direct it to www.yahoo.com
3. On the second window go to the menu File -> Save As.. to open the Save As
dialog box
4. With the dialog box still open, switch back to the first FireFox window and
try to search for something on Google; indeed, actually hit the Google Search
button.
5. Try not to fall asleep as you wait for FireFox to react to your search request..

Actual Results:  
In my limited tinkering with this, I find that FireFox goes comatose while
waiting for the modal Save As window from the second browser window to complete
its business. As soon as I hit Cancel or complete the Save As avtivity and the
dialog box closes, the first window completes the search request on google as
expected.

Expected Results:  
Like other browsers, new windows should be completely independent from one
another and not block each other's resources. The second window should not
affect the behavior of the first window beyond changes to saved preferences and
bookmarks and such things. The google search should go through normally while
the second window sits patiently in the background waiting for the user to
complete the Save As function.

Again, Save As may only be one of MANY examples where a dialog box or context
menu or something in one window will block the functions of a second window. I
have not gone to lengths to discover exactly the scope/depth of the problem. I
also anticipate that the problem might be limited to the Windows platform
version given the architectural differences between X/GTK systems and Windows.

Comment 1

14 years ago
I can confirm this behaviour in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8a5) Gecko/20041123 Firefox/0.9.1+

Comment 2

14 years ago
IMO this is a dupe of Bug 74331.
(Reporter)

Comment 3

14 years ago
Re: comment #2 from ostgote@gmx.net, indeed starting at comment number three for
bug 74331 it sounds like crossover.

*** This bug has been marked as a duplicate of 74331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.