charset parameter using quoted-string ignored

VERIFIED DUPLICATE of bug 244964

Status

()

Core
Networking: HTTP
VERIFIED DUPLICATE of bug 244964
14 years ago
14 years ago

People

(Reporter: Nir Soffer, Assigned: Darin Fisher)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When using charset parameter using quoted-string, Mozilla/Firefox ignore the
charset and use the charset defined in the head meta tag.

Example: Content-Type: text/html; charset="iso-8859-8"

According to href="http://www.w3.org/Protocols/rfc2616/rfc2616-sec3.html#sec3.7,
media type e.g. text/html can use parameters using format specified in
http://www.w3.org/Protocols/rfc2616/rfc2616-sec3.html#sec3.6. The quoting is not
needed in this case, but this seems to be valid HTTP 1.1 content type declaration.

 * IE 6.0 also ignore such charset
 * Safari respect it
 * W3C HTML validator respect this charset

Compare with same testcase using token: 'Content-Type: text/html;
charset=utf-8'. Here Mozilla works fine. http://nirs.dyndns.org/cgi-bin/token.cgi

Reproducible: Always
Steps to Reproduce:
1. Visit testcase url

Actual Results:  
Page rendered using charset defined in head meta tag

Expected Results:  
Page should render in charset defined in HTTP header Content-type
(Reporter)

Comment 1

14 years ago
Created attachment 167131 [details]
testcase cgi source

The source of my Python cgi testcase.

*** This bug has been marked as a duplicate of 244964 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
V/dupe
Status: RESOLVED → VERIFIED
QA Contact: core.networking.http → benc
You need to log in before you can comment on or make changes to this bug.