[PP] ALT tag not displayed upon resize if image broken

VERIFIED FIXED in M6

Status

P2
normal
VERIFIED FIXED
20 years ago
10 years ago

People

(Reporter: elig, Assigned: pavlov)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
* TITLE/SUMMARY
[PP] ALT tag not displayed on Linux if image broken

(broken out of bug #694)

* STEPS TO REPRODUCE
0) Launch Viewer
1) Point Viewer to http://www.prometheus-music.com/gecko/bug694.html (text
appended)

* RESULT
 - What happened

A broken image (broken-image.gif) exclusively appears; no ALT text displayed.

 - What was expected

Behavior on 4.5 is to display the broken image with the alt text in a box. (Bug
#1994 describes alternative behavior under future consideration.)

* REGRESSION

 - Occurs On
        viewer (1.27.99 optimized build for Linux)

 - Doesn't Occur On
        viewer (1.27.99 optimized build for Mac OS)
        viewer (1.27.99 optimized build for Win32 [NT 4, Service Pack 3])

* HTML SNIPPET (from URL)

<img src="bla.gif" width=200 height=200 alt="blu">


* CONFIGURATIONS TESTED

- [Mac] Power Mac 8500/120 (233 Mhz 604e), 64 MB RAM (VM on; 1 MB of VM used),
1024x768 (Thousands of Colors), Mac OS 8.5.1

- [Win32] Vectra VL (233 Mhz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP3.

- [Linux] Vectra VL (266 Mhz P2), 32 MB RAM (blech).
(Reporter)

Comment 1

20 years ago
I neglected to note this in the bug report (it happens fast, even with 32 MB of
RAM) ---

Before the broken image icon is drawn, Viewer *will* draw a box with the ALT
text, and then erase it to draw the broken image icon in the upper-left hand
corner of the screen.

Updated

20 years ago
Assignee: rickg → kmcclusk

Comment 2

20 years ago
Can you dig into this? It may be a rendering problem.

Comment 3

20 years ago
Inserting Milestone info.

Comment 4

20 years ago
Setting all current Open/Normal to M4.
(Reporter)

Updated

20 years ago
Summary: [PP] ALT tag not displayed on Linux if image broken → [PP] ALT tag not displayed upon resize if image broken
(Reporter)

Comment 5

20 years ago
Using the:
	- 2.18.99 Mac OS (Viewer & Apprunner)
	- 2.22.99 Linux (Viewer; didn't check Apprunner)

...builds, the ALT tag is now correctly displayed, but is replaced with a broken
image icon upon resizing the document.

Updated

20 years ago
Assignee: kmcclusk → pavlov

Comment 6

20 years ago
marking all non-functionality m4 bugs of mine to m5 as i won't be around for the
next week or two.

Comment 7

20 years ago
marking assigned

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Comment 8

20 years ago
This works in my build as of April 23 or so.  Could someone please verify?
(Reporter)

Updated

20 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 9

20 years ago
Pavlov,

	Technically, this bug no longer happens. I'm not sure if it's actually
fixed, hence the following question.

	Are we specifically no longer displaying a broken image icon and associated
frame when an image cannot be loaded, and just providing the plain text label?

	That's what's happening, and I'm not aware of any specification covering
this behavior.

	Thanks. (Re-opening bug just to ensure that you see the above question.)

Comment 10

20 years ago
From what I understand, the broken image isn't supposed to be displayed.  The
alt tag is supposed to be shown, so that if you have something the image alt
tag will fit right in with the paragraph.  I could be wrong though.  Feel free
to mark this as resolved or whatnot.  Pam, any ideas?

Updated

20 years ago
Status: REOPENED → ASSIGNED
Target Milestone: M5 → M6

Comment 11

20 years ago
clearing resolution, marking assigned, moving to m6 so that we can verify this
one better.

Updated

20 years ago
Resolution: FIXED → ---
This bug is one of many related to alternate text of images. All these bugs
have been marked. To find related bugs, search the description field for the
string "[ALT]".

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED

Comment 13

20 years ago
according to: http://www.w3.org/TR/REC-html40/struct/objects.html#adef-alt

"Several non-textual elements (IMG, AREA, APPLET, and INPUT) let authors specify
alternate text to serve as content when the element cannot be rendered
normally."

so I believe that it is doing the right thing.  I am going to mark this one as
fixed.
(Reporter)

Comment 14

20 years ago
As of the 5.15.99 build, yes, it is doing the right thing on all three platforms
(the ALT tag is displayed, and remains displayed upon resize.)

On Win32, there is a slight deviation; I'll write that up as a separate bug, and
reference the bug number here.
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 15

20 years ago
The side-issue (broken image icon changes upon resize if running Win32) is now
bug #6559.

Thus, this bug is now marked as Verified.
This bug reopened, but there doesn't seem to be any particular reason for it to
have done so. The Bug Activity Log shows no activity since May 27th!

I am going to e-mail Terry. I suggest no-one touch this bug anymore until we
have worked out what happened.

Comment 17

20 years ago
I think that pavlov has reassigned this bug (from pavlov@pavlov.net to
pavlov@netscape.com), which caused it to be reopened.  The question, though, is
why this didn't show up in the activity log.
(Assignee)

Comment 18

20 years ago
sorry for bugzilla spam.  trying to get these off my radar
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 19

20 years ago
Re-flagging as Verified.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.