If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Downloads larger than 2.1gb go negative

VERIFIED DUPLICATE of bug 228968

Status

()

Toolkit
Downloads API
--
trivial
VERIFIED DUPLICATE of bug 228968
13 years ago
9 years ago

People

(Reporter: Nate Solberg, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I believe the variable is too small for download sizes greater than 2.1gb. I
wasn't watching it exclusively, however when I checked it around 2.2 it had
negative numbers for size and speed. 

I hope you understand that I'm not going to try to reproduce this because it's
fairly mild, and probably just an "int" instead of a "long." The file still came
in fine, just a cosmetic thing.

Reproducible: Didn't try
Steps to Reproduce:
1.Start a large download (like the Fedora 3 DVD Installer)
2.Watch to see when it changes over


Actual Results:  
The speed and size of the download switched over to negative numbers. Usually
when I've seen this in other programs, it's just a variable not being big enough.

Expected Results:  
Use a larger variable since we can download DVD's now, not just CD images.

I only did this on an Athlon 64 running Windows 2000. 

I doubt it is a platform specific thing though, unless Mac's use bigger "int"s.
(In reply to comment #0)
> I doubt it is a platform specific thing though, unless Mac's use bigger "int"s.

They aren't bigger, just somehow, undefinably, better, and well worth the extra
memory involved in storing the same size numbers.

*** This bug has been marked as a duplicate of 184452 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
no, this is a duplicate of bug 228968
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 228968 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Comment 4

13 years ago
v
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.