Form focus moves from Current Tab Page to Non focus tab page loading a new form

VERIFIED DUPLICATE of bug 124750

Status

()

--
minor
VERIFIED DUPLICATE of bug 124750
14 years ago
14 years ago

People

(Reporter: dylanpugh, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

Form focus moves from Current Tab Page to Non focus tab page loading a new form.
E.G.
I create 2 tabs, then in one I go to www.netaddress.com, then in the other I go
to www.hotmail.com, I then go back to the www.netaddress.com page because by now
it has loaded and I can enter my username and password - but while writing my
username and password the focus is lost to the form on the www.hotmail.com tab,
even though that tab is NOT  currently in focus. - Very annoying especially
since I like my username to appear in the text box in the www.hotmail.com tab
because it's awkward to type.

Reproducible: Always
Steps to Reproduce:
1. Create 2 tabs
2. GO to tab 1, Open a page like www.netaddress.com
3. While tab 1 is loading, go to tab 2 and open a page to www.hotmail.com
4. While tab 2 is loading, go back to tab 1 and start entering your username and
password. While you are doing this tab 2 has loaded in the background and takes
the form focus from tab 1 even though tab 1 is still in the foreground.

Actual Results:  
4. While tab 2 is loading, go back to tab 1 and start entering your username and
password. While you are doing this tab 2 has loaded in the background and takes
the form focus from tab 1 even though tab 1 is still in the foreground.


Expected Results:  
The focus should not have gone to the tab that is not currently in the foreground.

Comment 1

14 years ago
Please don't file bugs with 6-month old versions of Firefox, thanks.

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.