in a select form element the onchange event is called when selecting with mouse but not when using up and down key

RESOLVED DUPLICATE of bug 126379

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 126379
13 years ago
13 years ago

People

(Reporter: m.stoedtler, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041122 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041122 Firefox/1.0

Example:
Focussing the element and click up/down should also trigger the coming up of the
alert box, but it doesnt.

<select onchange='alert("test");'>
<option value="1">Test1</option>
<option value="1">Test2</option>
<option value="1">Test3</option>
<option value="1">Test4</option>
</select>

Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
The onchange event should also be called when the user uses the up/down keys.

I'm not shure if the bug is critical, but some pages will have to deal with data
that loses integrity.
(Reporter)

Comment 1

13 years ago
Created attachment 167531 [details]
This page shows the bug

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.