Closed Bug 272787 Opened 15 years ago Closed 13 years ago

After a random amount of time, unable to connect to anything

Categories

(Firefox :: General, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jon.baumgartner, Unassigned)

References

Details

(Whiteboard: [asaP2])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041115 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041115 Firefox/1.0

After a random amount of time, unable to connect to anything. I can't discern a
pattern. After a while, clicking on any link will result in Firefox waiting
indefinitely for the page to load. The workaround is to take Firefox offline,
and then back online. Pages will then load for another random period of time
until the problem occurs again.

Reproducible: Sometimes
Steps to Reproduce:
1. Use Firefox for a while
2. Attempt to go to a new location (either by clicking a hyperlink or typing it
in the address bar)


Actual Results:  
Firefox waits indefinitely until stopped.

Expected Results:  
Loaded the web page.
Severity: normal → major
This has happened to me quite a few times, usually with heavy amounts of tabbed
browsing (though that may not be the cause).

This has only happened on Windows XP SP2 laptop and Windows XP SP2 desktop, and
has not happened on my Windows 2000 work desktop.
Worth noting I'm also running XP SP2, and I tend to have a lot of tabs open as well.
Is it XP SP2's TCP connection throttling (
http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/sp2netwk.mspx) at
work here?  There's now a limit of 10 simultaneous incomplete outbound TCP
connection attempts.  If so, your event log should show event 4226.
No, this is discussed in Mozillazine forums here
http://forums.mozillazine.org/viewtopic.php?t=174908 and is occuring on people
with SP1.
Happining to me as well on Windows 2000 at work.  I'm not sure what kind of a
connection we have but I tested up to 11Mbps, so I don't think bandwidth is my
problem.  I started to notice this problem when I tried to install a night trunk
build unsuccessfully and then reinstalled 1.0.
Any news on this? Isn't this a blocker? If someone switches from IE to Firefox,
and Firefox stops working, they're probably going to switch right back to IE.
I'm still seeing this with recent nightlies.
Flags: blocking-aviary1.1?
we can't block for what we can't reproduce effectively.

Darin, any idea what could be up with this?
If someone can capture a Mozilla HTTP log when the problem happens that would be
great!  See instructions here:

http://www.mozilla.org/projects/netlib/http/http-debugging.html

Please zip up the log file before attaching it to this bug report.  Thanks!
I managed to get this to happen again, but since the bug is so intermittent, it
took a while to reoccur. The resulting log is about 120 MBs. 7 MBs when zipped.
I could just include the last part of the log, but I'm not quite sure what's
relevant.
hrm, this just happened to me and I really thought for I second I was going
crazy. More effort should be put on this bug, I can see why someone would want
to switch to anything else seeing that his/her browser just stops working after
a while. (Most of the users are not geeks that are used to restart applications)

What could we do to narrow it down?
Jon, could you email the log to one of us? Darin, do you have room to receive
that? If not, I could and I could.

Surely this bug belongs in Core somewhere and not in Firefox General.
Whiteboard: [asaP2]
(In reply to comment #11)
> Jon, could you email the log to one of us? Darin, do you have room to receive
> that? If not, I could and I could.
> 
> Surely this bug belongs in Core somewhere and not in Firefox General.

Asa, I tried to email it to you, but it bounced:

Remote host said: 552 Message size exceeds fixed limit

I put it up on my server:

http://www.bergenstreetsoftware.com/temp/272787_log.zip
I took a quick look at the log posted and the only suspicious thing I noticed is
that the end of this log contains a repeating pattern of all connections waiting
in the idle state, i.e.:
...
nsHttpConnectionMgr::ProcessPendingQForEntry [ci=..www.mozilla.ru:80]
...
2728[35e0550]:   idle [43] { handler=38e5be8 condition=0 pollflags=0 }
...

I'm not a mozilla hacker, but I hope that helps
More information:

When this bug happens, the browser will hang indefinitely after clicking on a
hyperlink. When I click "stop loading this page," the text in the status bar
changes to "Stopped." 

I don't think I've ever seen "Stopped" in the status bar before. Hopefully this
will help a bit more.
Btw. Jon, Corey: do you use proxy severs for accessing the web pages?
(In reply to comment #15)
> Btw. Jon, Corey: do you use proxy severs for accessing the web pages?

Nope.
I get a similar error:

Operation timed out when connecting to…

www.mozilla.org could not be found. Please check the name and try again.

I repeatedly receive these one of these two messages when browsing. The first
appears regularly and the second occasionally. In both instances the links
clicked on are active; I then click on the same link again and the page opens
up. This is especially evident with tabbed browsing.
Interesting. Changing the Compatibility Mode settings for Firefox.exe seems to
fix this problem. At least, I've been running now for several hours without
trouble, whereas before I was seeing this every 15 minutes or so.

I went to Firefox.exe's properties, and selected the Compatibility tab. I then
checked "Run this program in compatibility mode for" and chose "Windows
98/Windows ME."

Perhaps this offers a clue?
without steps to reproduce, not going to happen before beta.
Flags: blocking-aviary1.1? → blocking-aviary1.1-
Could be related... I have noticed that on Fedora Core 3 and 4 that Firefox at
some unknown time just plain disconnects itself from the net... Meanwhile
Konqueror continues to connect just fine. I either have to restart FFox or reset
the conncetion setting from directly connected to auto... and then back again.

(In reply to comment #18)
> Interesting. Changing the Compatibility Mode settings for Firefox.exe seems to
> fix this problem. At least, I've been running now for several hours without
> trouble, whereas before I was seeing this every 15 minutes or so.
> 
> I went to Firefox.exe's properties, and selected the Compatibility tab. I then
> checked "Run this program in compatibility mode for" and chose "Windows
> 98/Windows ME."

Sadly, this didn't work long-term. Problem came back.
Just noticed this today (with build Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.8b4) Gecko/20050725 Firefox/1.0+):

Previously, I could work around this by stopping loading, then taking Firefox
offline, and back online, followed by a reload. What I noticed today was that if
I don't stop first, but simply go offline and back online while the page is
still loading, the page will then continue to load. This even worked for tabs
that were loading in the background.

So it appears that something gets stuck, and then gets unstuck by going off- and
back on-line. Perhaps the idle state discussed in comment #13?
Is this bug similar to this one? (connection stop working to one server, but no
problems with another server):
https://bugzilla.mozilla.org/show_bug.cgi?id=248253
*** Bug 330500 has been marked as a duplicate of this bug. ***
I experience this all the time, a couple of times a day. Firefox can't resolv "new" hostnames, but after a minute or two it works just fine again all by it self.

My system:
Windows XP Professional Version 2002 Service Pack 2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
I have disabled ipv6-DNS-lookup in Firefox.
Assignee: bross2 → nobody
Not sure when this resolved itself, but it's definitely gone with this build:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070528 Minefield/3.0a5pre ID:2007052804 [cairo]

Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Well people, I've been experiencing this problem for more than 6 months (prolly closer to 9). I can't remember from exactly what version but I'm always up-to-date and now running 2.0.0.5. Have reinstalled Shitdoze (with a proper format (4-pass DoD diskwipe)) since the thing started happening so it has nothing to do with leftover files or previous installations of Firefox.

I can also tell you that;
1. it only happens with FF (I use 5 browsers)
2. it only happens on some websites (www.demonoid.com & www.amazon.com are the two that it happens most on*)
3. like the OP, I have multiple tabs open (usually more than 20 and sometimes up to 60) and consequently FF always uses more than 200MB of RAM (125 minimum, 380-400 max)
4. I have the browser open for weeks at a time (do not reboot)
5. it usually happens once FF has been open for at least a few days or a week
6. whenever I restart FF it resets and behaves normally (at least initially)


* I'm pretty sure it's nothing to do with the way these sites are coded or how busy they are (Demonoid is often overloaded but no other member has complained about this problem). I think it has to do with the fact that I always have more tabs open (and consequently using more RAM) on these sites than I do others. It never happens on Yahoo, Hotmail, Google etc but I only ever have one or two tabs open from those sites


I haven't tried the IPv6 or the working offline then going back online ideas but I will do and get back to you regarding them. Problem is that I had a point where it wasn't misbehaving for a period of 6-8 weeks so god knows if playing the waiting game will work. Time will tell.

Will be posting back as soon as I have any news and I hope that some of the above was useful for the devs.

Regards,
Med
You need to log in before you can comment on or make changes to this bug.