Extra space between number and Hebrew text for "font: sans-serif"

RESOLVED DUPLICATE of bug 294376

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 294376
13 years ago
9 years ago

People

(Reporter: Uri Bernstein (Google), Assigned: mkaply)

Tracking

({qawanted, testcase})

Trunk
PowerPC
Mac OS X
qawanted, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
When the font is specified as "sans-serif", at certain font sizes, an abnormaly
large space appears between numbers and the Hebew text following them. The
amount of space seems to depend on the length of the following text. Selecting
the line leaves this extra space unselected.
Specifying the sans-serif font by name (e.g. Helvetica) eliminates the problem.

This is probably a Mac-specific issue (I don't remember seeing it on other
platforms), so the correct component might be "GFX: Mac".

Seen on:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107
Firefox/1.0
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a6) Gecko/20041202
Firefox/1.0+
(Reporter)

Comment 1

13 years ago
Created attachment 167751 [details]
testcase

The two lines should look the same (when the default sans-serif font is
Helvetica). The first line uses "font: sans-serif" and exhibits the problem.
(Reporter)

Updated

13 years ago
Keywords: testcase
Keywords: qawanted
(Reporter)

Comment 2

13 years ago
This is almost certainly just a special case of bug 294376 - in which I've done
some more research and given a better testcase. I'm closing this one as a
duplicate, at least until proven otherwise.

*** This bug has been marked as a duplicate of 294376 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.