Closed Bug 273144 Opened 16 years ago Closed 16 years ago

When hovering over links on right, long Anchor tag "titles" are truncated and display line breaks as squares

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
trivial

Tracking

()

RESOLVED DUPLICATE of bug 67127

People

(Reporter: rs25com, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

In the home page at http://www.rs25.com there are several boxes down the right
column.  If you hover over the title, the Anchor tag's "title" attribute will
display a short description of the content of the topic.  In IE all of the
content is correctly displayed, including line breaks, and it will often be more
than one line high.  In FireFox, only one line is displayed, to about 30-50
characters (even if there are more) and line breaks are displayed as little
black squares.  

Reproducible: Always
Steps to Reproduce:
1.  Go to www.rs25.com
2.  Hover your mouse over any of the links on the right column of recent topics
3.  View the pop-up title description.
4.  Repeat with Internet Explorer 6.x and you'll see it displays the complete
pop-up title description, which is much longer and formatted properly.

Actual Results:  
In my example, I hovered over a link with FireFox and it said:
----------------
Hi All [][] (black squares) we finished our initial dyno runs <snip> you can
check out the...
----------------

With Internet Explorer it does this:
----------------
Hi All,

We finished out initial dyno runs <snip> check out all the information on our
web site ...

Last post by Ampsarus on Today at 12:51pm
----------------


Expected Results:  
The software should display all of the content that is specified in the HTML "A"
tag for the hyperlink, and process the <br> as a line break, not display little
black boxes.

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
This is almost certainly a dup of a lengthy bug on ALT and/or TITLE 
attributes.

To the best of my knowledge, Firefox is consistent with the standards
here, and I bet that this is a WONTFIX; sorry.

Kindly note that I get this assertion on your page:


###!!! ASSERTION: this doesn't do anything: 'NS_UNCONSTRAINEDSIZE !=
aReflowState.availableWidth', file
../../../../../../src/layout/html/table/src/nsTableFrame.cpp, line 1957
Break: at file ../../../../../../src/layout/html/table/src/nsTableFrame.cpp,
line 1957

(It is line 1962 on lxr)
You need to log in before you can comment on or make changes to this bug.