Copying HTML from textbox/textarea strips tags

VERIFIED DUPLICATE of bug 273741

Status

()

--
critical
VERIFIED DUPLICATE of bug 273741
14 years ago
13 years ago

People

(Reporter: jruderman, Assigned: mozeditor)

Tracking

({dataloss})

Trunk
x86
Windows XP
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Steps to reproduce:

1. Copy from the textarea in data:text/html,<textarea>&lt;li&gt;foo.
2. Paste anywhere (same textarea, Notepad, etc.)

Result: "# foo" pasted.
Expected: "<li>foo" pasted.

This regression first appeared in Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.8a6) Gecko/20041207 Firefox/1.0+.  The December 6 build did not have
this bug.
(Reporter)

Updated

14 years ago

Comment 1

14 years ago
This might be caused from the Checkin for Bug 244685 at 2004-12-07 06:13

Updated

14 years ago
Component: Editor → Drag and Drop

Comment 2

14 years ago
I just crashed in nsCopySupport::HTMLCopy because ConvertedData was null.

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 273741 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
No longer depends on: 273741
Resolution: --- → DUPLICATE
(Reporter)

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.