faulty handling of " and &quot; with tags ( <img> for eg) WITHIN a <textarea> tag

RESOLVED DUPLICATE of bug 154882

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 154882
13 years ago
13 years ago

People

(Reporter: N Brooks, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I run a forum, and for message preview I need to prefill the textarea from a
previous copy, users who enter for example an img tag, but miss off the closing
quote around the URL are currently corrupting the next page.

The 2 examples linked here are self contained, view them and you will see the
problem.

http://www.nigelbrooks.com/textarea1.html
- this file has an unmatched " inside the textarea, FireFox misses the
</textarea> tag, and include extra code in the edit box.

http://www.nigelbrooks.com/textarea1.html
- I tried using &quot; (&amp;quot; - in case this is parsed here) to get around
this, which half works, at least it sees the </textarea> tag, but inside tags
within the textarea, &quot; (&amp;quot; - in case this is parsed here)is NOT
converted to " (it is outside any other tags)

The pages give more details. BOTH versions work fine with IE (6) and NetScape
4.76, I've not tried with anything else...



Reproducible: Always
Steps to Reproduce:
1. view either of the pages !
2.
3.

Actual Results:  
see details

Expected Results:  
see details - and see IE or NetScape for the correct results !
THERE SHOULD BE NO PARSING DONE INSIDE TEXTAREA TAGS

I tried adding this to bug 273201 which may be the same, but it didn't seem to
come up.  This is a serious BUG and breaks my forum, and several others that
I've tried it on.

Comment 1

13 years ago
Both (I presume you meant to cite textarea2.html as the other example) WFM
20041209 trunk PC/Win2000.
Severity: blocker → normal
Component: Form Manager → General

Updated

13 years ago
Assignee: bugs → firefox
QA Contact: firefox.form-manager → firefox.general
There are two seperate bugs reported here, and they're both fixed on the trunk
(by bug 88952. I'll mark this as a duplicate of one of them.

Reporter, please note that having < within <textarea> is illegal, you should
always escape your '<'s with &lt;. The HTML spec doesn't specify how tags inside
<textarea>s should be handled (so parsing them is technically allowed).

*** This bug has been marked as a duplicate of 154882 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.