Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Venkman 0.9.83 (and trunk) doesn't display loaded scripts on trunk

RESOLVED WORKSFORME

Status

Other Applications
Venkman JS Debugger
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Sean McMurray, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

The "Loaded Scripts" pane shows twisties (I guess one twisty per open file?),
but no text (like filenames, function names, etc).

Doublechlicking a twisty or one of its children opens a file in the "Source
Code" pane. However, setting a breakpoint in that file creates a similar
behavior in the "Breakpoints" pane. You can see the twisty, but no text.

Setting watches in the "Watches" pane has similar problems. You can highlight
the watch, but there is not text.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
Care to give us some /useful/ information?

Where did you get version 0.9.83 from?
What are you installing it into?

If you're using the special Firefix 1.0 branch version in trunk Moz/FF this is
expected. The same goes for using a trunk version in the Firefox 1.0 branch.

Comment 2

13 years ago
The same goes for the Mozilla 1.7 branch, btw.
(Reporter)

Comment 3

13 years ago
ah ha. I'm using Mozilla 1.7.

I got the download from http://www.hacksrus.com/~ginda/venkman/ .
It warned about firefox, but not about Mozilla 1.7.

Comment 4

13 years ago
rginda, where did you get the 0.9.83 XPI from for the
http://www.hacksrus.com/~ginda/venkman/ page? Hm, looks like it really is a
trunk Mozilla one.

Also, it needs to be pointed out that the 0.9.84 version will NOT work in trunk
Firefox (which will become FF 1.1) because it will have exactly the problems
described in this bug.

Basically, (of the versions from hacksrus.com) 0.9.83 will only work in trunk
Mozilla (post-1.7), and 0.9.84 will work in Firefox 1.0 and Mozilla 1.7 ONLY
(not any other versions).

Sean McMurray, since you have Moz 1.7, I suggest you try 0.9.84 as I believe
that version will work.

We do need to fix the problem that 1.7/1.0 is not compatible with trunk. I
believe the only bit that is broken is tree-utils.js.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: venkman 0.9.83 doesn't display loaded scripts → Venkman 0.9.83 (and trunk) doesn't display loaded scripts in Moz 1.7
Version: unspecified → 1.7 Branch
(Assignee)

Comment 5

13 years ago
Yeah, I pulled it from a trunk tarball, I think.

Comment 6

13 years ago
Summarizing, there is no working version for the current Firefox trunk builds (?).

If so, and since i get the same thing - as predicted in Comment #4 - with
Venkman 0.9.84 in...
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20041214
Firefox/1.0+
..., i'd suggest widening title, summary, OS, and version.
(Assignee)

Updated

13 years ago
OS: Linux → All
Summary: Venkman 0.9.83 (and trunk) doesn't display loaded scripts in Moz 1.7 → Venkman 0.9.83 (and trunk) doesn't display loaded scripts on trunk
Version: 1.7 Branch → Trunk

Comment 7

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a6) Gecko/20041215
Firefox/1.0+

(Trunk build using standard methods)

If Venkman works at all on the Mac, and since I am seeing the same as
comment 4 , I am hopeful; which version do I want.

The http://www.hacksrus.com/~ginda/venkman/ page has "Revision 0.9.84 is 
the FIREFOX ONLY build of Venkman. It will only work on Firefox. Other 
versions of Venkman will probably NOT work on Firefox. If you're not using
Firefox, you should install 0.9.83 instead", and I suspect that many people 
would choose 0.9.84 from this instruction.

Comment 8

13 years ago
(In reply to comment #7)
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a6) Gecko/20041215
> Firefox/1.0+
> 
> (Trunk build using standard methods)

You are using a trunk Firefox nightly. There is no version of Venkman for this.
(Mac should have no difference, all versions should work equally across all
platforms)

Comment 9

13 years ago
Thank you.

Am I right in thinking that the truth table for which versions are 
appropriate looks something like:

--------------------------------------------
       | Firefox | Suite  | Gecko | Version |
-------+---------+--------+-------+---------       
Branch | 0.9.84  | 0.9.83 | 1.7   | 1.0     |
Trunk  | None    | 0.9.83 | 1.8a6 | 1.0+    |
--------------------------------------------

Comment 4 suggests that 0.9.84 (also) should work in Suite 1.7/1.0, 
but most other info is thst 0.9.84 is Firefox only.

Is there anything that a contributor can do to accelerate the development
of a Firefox trunk Venkmann version such as the one that Comment 1 hints 
at (I assume that there will be one)?
(Assignee)

Comment 10

13 years ago
I've updated the Venkman development page to reflect the fact that Venkman
doesn't work in the trunk.

Comment 11

13 years ago
0.9.84 must be used for the 1.7 branch.

Comment 12

13 years ago
This seems to be fixed with version 0.9.85. Can we resolve this bug?

Comment 13

12 years ago
This bug stop me from using 1.5b for work. Some time I need to debug my
javascript code.

I hope this bug will be fixed beofore Firefox 1.5 release

Comment 14

12 years ago
(In reply to comment #13)
> This bug stop me from using 1.5b for work. Some time I need to debug my
> javascript code.

My understanding was that comment 12 applies.

Malix, could you give details and in particular confirm which versions
of Firefox, the debugger service (JSD) and Venkman you are using.

Comment 15

12 years ago
Works fine on 20060325 trunk Venkman/Firefox for me. Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.