Firefox fails to recognise Atom feed <link>s with spaces or non-lowercase letters in the "type" attribute.

RESOLVED DUPLICATE of bug 257247

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 257247
15 years ago
15 years ago

People

(Reporter: porges, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

As shown by the following tests:

http://diveintomark.org/tests/client/autodiscovery/xhtml11-014.xhtml
http://diveintomark.org/tests/client/autodiscovery/xhtml11-015.xhtml
http://diveintomark.org/tests/client/autodiscovery/xhtml11-016.xhtml
http://diveintomark.org/tests/client/autodiscovery/xhtml11-017.xhtml
http://diveintomark.org/tests/client/autodiscovery/xhtml11-018.xhtml
http://diveintomark.org/tests/client/autodiscovery/xhtml11-038.xhtml
http://diveintomark.org/tests/client/autodiscovery/xhtml11-039.xhtml
http://diveintomark.org/tests/client/autodiscovery/xhtml11-040.xhtml
http://diveintomark.org/tests/client/autodiscovery/xhtml11-055.xhtml

Reproducible: Always
Steps to Reproduce:
Visit one of the pages linked to.
Actual Results:  
No "Add live bookmark" icon appears in the status bar.

Expected Results:  
Discovered the feed which the page links to.
I should probably get back to trying to balance discovery according to spec and
discovery according to real-world <link>s written by people who didn't find the
spec-blog-post.

*** This bug has been marked as a duplicate of 257247 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.