Dependencies should prefer aliases to bug numbers.

RESOLVED DUPLICATE of bug 470262

Status

()

Bugzilla
Creating/Changing Bugs
--
enhancement
RESOLVED DUPLICATE of bug 470262
14 years ago
8 years ago

People

(Reporter: CodeMachine, Unassigned)

Tracking

unspecified
Bug Flags:
blocking3.0 -

Details

(Reporter)

Description

14 years ago
The two dependency fields on show_bug show bug numbers.  If there's an alias, it
should display it instead, both for the read-only hyperlink and the editable
text field.
what happens if someone changes which bug owns that alias while someone is
viewing the bug?
(Reporter)

Comment 2

14 years ago
Perhaps a relevant alias->bug mapping embedded in hidden fields would be the
appropriate solution.
(Reporter)

Comment 3

14 years ago
Actually upon reflection this is an issue for most fields, one that we have done
nothing about (and my suggested implementation or similar has been suggested
before for it).  It might be more prevalent for aliases though.

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa

Comment 4

12 years ago
i can't mark blocking 3.2.

I agree with Matthew Tuck's suggestion. use a hidden mapping.

We can use this to generate a midair collision.

We should actually improve collisions to offer
(*) Colliding
( ) Unchanged user value
( ) Pick something new: [             |v]

But that's not necessary.

I think that if we implement this and one other thing, I can probably make a proposal to deal with the problem of detecting whether bugs are in versions / should block releases.
Flags: blocking3.0?

Comment 5

12 years ago
This is obviously not a blocker, as it is an enhancement.
Flags: blocking3.0? → blocking3.0-

Comment 6

12 years ago
If a public bug blocks a security-sensitive bug, and the security-sensitive bug has an alias, should people not in the security group see the alias when they load the public bug?

Comment 7

12 years ago
(In reply to comment #6)
> If a public bug blocks a security-sensitive bug, and the security-sensitive bug
> has an alias, should people not in the security group see the alias when they
> load the public bug?
> 

Of course not.

Updated

12 years ago
Assignee: myk → create-and-change

Comment 8

8 years ago
Already implemented in Bugzilla 3.4.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 470262
You need to log in before you can comment on or make changes to this bug.