Radio button 3D Status not correct initially & after change

VERIFIED DUPLICATE of bug 25258

Status

()

Core
Layout: Form Controls
P3
minor
VERIFIED DUPLICATE of bug 25258
19 years ago
19 years ago

People

(Reporter: Dwayne, Assigned: saari (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build 2000-02-11-08, WinNT 4.0 SP6a

When loading a form with radio buttons that are checked by default, the 3D
appearance is not set correctly.  Although correctly selected and highlighted,
the button appears to be 'protruding' as if it were unselected.

Hovering over the button and moving away does not change its status, but
clicking on the already-selected radio button will correctly reset its 3D presence.
(Reporter)

Comment 1

19 years ago
Further (accidental) testing revealed another, interesting problem on the same
build:

When selecting another radio button in the set, the 'depressed' 3D appearance of
the previously selected radio button is not reset UNTIL you hover over it.

Comment 2

19 years ago
A cosmetic problem, but the 3D effect should always mirror the selection
in a group of radio buttons.
Assignee: leger → karnaze
Component: Browser-General → HTML Form Controls
QA Contact: cbegle → ckritzer
Summary: Radio button 3D Status → Radio button 3D Status not correct initially & after change

Comment 3

19 years ago
*** Bug 27426 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
marking beta1 - this is a fairly major regression with the URL bar not updating
Keywords: beta1

Comment 5

19 years ago
okay it's late and I got my bugs transposed, i meant 27445, please ignore me, 
removing beta1 from keyword
Keywords: beta1

Comment 6

19 years ago
Reassigning to Rod.
Assignee: karnaze → rods

Comment 7

19 years ago
The 'sunken" look is when the radiobutton has focus. Right now focus is broken 
so the previously focuse object doesn't get the unfocus message in order to 
redraw itself as no longer having focus. I have included the radio rules here so 
you can see:
input[type=radio] {
  box-sizing: border-box;
  /* these margins are for NavQuirks, we need a Standard ua.css */  
  margin-left:   3px;   
  margin-right:  5px;  
  margin-top:    2px; 
  margin-bottom: 4px; 
  border: 2px outset rgb(153, 153, 153);
  background-color:rgb(204, 204, 204);
  color:black;
  width:12px;
  height:12px;
  behavior: none;
  -moz-border-radius:6px;
}

input[type=radio][disabled] {
  border: 1px solid;
}

input[type=radio]:focus {
  border: 2px inset rgb(153, 153, 153);
}

input[type=radio]:hover {
  border : 2px solid black;
}

input[type=radio]:active {
  background-color: white;
}


This is a focus bug, therefore it is a Chris Saari bug.... reassigning
Assignee: rods → saari
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 8

19 years ago
Duplicate of 25258



*** This bug has been marked as a duplicate of 25258 ***

Comment 9

19 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.