Pressing Enter in Wizard activate BOTH focused button and pageAdvance()

RESOLVED FIXED

Status

()

Core
XUL
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: Leung Wing Chung, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Expected behavior:
a. If a button is focused, activate the focused button,
b. otherwise, activate pageAdvance()

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Created attachment 168740 [details] [diff] [review]
Patch of mozilla/toolkit/content/widgets/wizard.xml

Removed wrong check of dlgType="button"
If localName check is not enough, check also for the namespace.
(Reporter)

Comment 2

14 years ago
Created attachment 168742 [details]
Testcase (Install and then open chrome://testwizard/content/testwizard.xul)
xpfe/global/resources/content/bindings/wizard.xml needs the same change...

Comment 4

14 years ago
Created attachment 171632 [details] [diff] [review]
Patch for both wizard.xmls v0.2 (checked in)
Attachment #168740 - Attachment is obsolete: true
Attachment #171632 - Flags: review?(neil.parkwaycc.co.uk)

Updated

14 years ago
Attachment #171632 - Flags: review?(neil.parkwaycc.co.uk) → review+

Updated

14 years ago
Attachment #171632 - Flags: superreview?(bzbarsky)
Comment on attachment 171632 [details] [diff] [review]
Patch for both wizard.xmls v0.2 (checked in)

sr=bzbarsky.  Ian, can you check this in when the tree reopens?
Attachment #171632 - Flags: superreview?(bzbarsky) → superreview+

Comment 6

14 years ago
*** Bug 238794 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
Comment on attachment 171632 [details] [diff] [review]
Patch for both wizard.xmls v0.2 (checked in)

Checking in toolkit/content/widgets/wizard.xml;
/cvsroot/mozilla/toolkit/content/widgets/wizard.xml,v  <--  wizard.xml
new revision: 1.17; previous revision: 1.16
done
Checking in xpfe/global/resources/content/bindings/wizard.xml;
/cvsroot/mozilla/xpfe/global/resources/content/bindings/wizard.xml,v  <-- 
wizard.xml
new revision: 1.21; previous revision: 1.20
done
Attachment #171632 - Attachment description: Patch for both wizard.xmls v0.2 → Patch for both wizard.xmls v0.2 (checked in)

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.