source and browser rendering are not the same

VERIFIED DUPLICATE of bug 46845

Status

()

Toolkit
View Source
VERIFIED DUPLICATE of bug 46845
13 years ago
9 years ago

People

(Reporter: Justin, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I am using Coldfusion to dynamically generate HTML.  I have a form that has a
multi-select box on it.  When I pass a query string I am dynamically selecting
options in the select box.  However, if I manually select an option, it only
highlights that one I selected which is fine.  The problem is when I hit the
refresh button on the browser it should re-render the page.  I have my cache
turned off so that is not a problem.  When I hit the refresh, only the one I
last selected is highlighted.  When I view the source, the HTML shows all the
ones that should be selected, but the browser is not showing them.  It appears
as if the browser is not rendering the HTML source that is should.

Reproducible: Always

Comment 1

13 years ago
Reporter, this is because of the kind of strange Mozilla .. um, let's call it a
"feature", that causes form data entered to be saved in the browser history so
that it will still be filled in if the user navigates around and then comes back
through their history to the page.  But the strange thing is that it also
affects plain old refresh; to make the form values reset to those supplied by
the server, you should hold the shift key when you press the refresh button. 
This has nothing whatever to do with the Source View, but rather is a Session
History issue.  See Bug 46845 for the long and sordid story.  If I understand
the report, this is a duplicate of that bug (I don't have permission to dupe it,
but someone else should).

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.