scrolling with mousewheel in display:block element with overflow:auto not possible

VERIFIED DUPLICATE of bug 97283

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 97283
14 years ago
14 years ago

People

(Reporter: Lars Bilharz, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

Giving any block element, with enough content, the "overflow: auto" style
results in scrollbars. As the body scrollbars, also these scrollbars shall be
moved with turning the mousewheel. Best working sample it the behaviour of the
iframe. 


Reproducible: Always

Steps to Reproduce:
1. Open the link (http://www.larsattacks.de/test/scrollable)
2. place mouse over the content with the scrollbar /or click it to focus
3. turn the mousewheel

Actual Results:  
nothing (that's the bug)

Expected Results:  
behave like you would expect, move the content your mouse is over to the top.

middle click the mouse results in the whole page to be scrolled

Comment 1

14 years ago
Fixed, will be available in Firefox 1.1

*** This bug has been marked as a duplicate of 97283 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.